aboutsummaryrefslogtreecommitdiffstats
path: root/packages/main/src/stores/__tests__/SharedStore.spec.ts
diff options
context:
space:
mode:
authorLibravatar Kristóf Marussy <kristof@marussy.com>2022-01-27 01:02:02 +0100
committerLibravatar Kristóf Marussy <kristof@marussy.com>2022-02-08 21:43:17 +0100
commitda610a51f49807d1409f36b98e06e89447a4202b (patch)
treea4f7911f45ca52626ef02f370c3f260d33f8272e /packages/main/src/stores/__tests__/SharedStore.spec.ts
parentrefactor: Coding conventions (diff)
downloadsophie-da610a51f49807d1409f36b98e06e89447a4202b.tar.gz
sophie-da610a51f49807d1409f36b98e06e89447a4202b.tar.zst
sophie-da610a51f49807d1409f36b98e06e89447a4202b.zip
refactor: Extract config handling
Move the handling of the contents of the config file out of the stores and into dedicated files to simplify the code of the stores. Signed-off-by: Kristóf Marussy <kristof@marussy.com>
Diffstat (limited to 'packages/main/src/stores/__tests__/SharedStore.spec.ts')
-rw-r--r--packages/main/src/stores/__tests__/SharedStore.spec.ts7
1 files changed, 4 insertions, 3 deletions
diff --git a/packages/main/src/stores/__tests__/SharedStore.spec.ts b/packages/main/src/stores/__tests__/SharedStore.spec.ts
index dfd59a1..268ce3f 100644
--- a/packages/main/src/stores/__tests__/SharedStore.spec.ts
+++ b/packages/main/src/stores/__tests__/SharedStore.spec.ts
@@ -18,9 +18,10 @@
18 * SPDX-License-Identifier: AGPL-3.0-only 18 * SPDX-License-Identifier: AGPL-3.0-only
19 */ 19 */
20 20
21import type { ProfileConfig } from '../Profile'; 21import SharedStore from '../SharedStore';
22import type { ServiceConfig } from '../Service'; 22import type Config from '../config/Config';
23import SharedStore, { Config } from '../SharedStore'; 23import type ProfileConfig from '../config/ProfileConfig';
24import type ServiceConfig from '../config/ServiceConfig';
24 25
25const profileProps: ProfileConfig = { 26const profileProps: ProfileConfig = {
26 name: 'Test profile', 27 name: 'Test profile',