aboutsummaryrefslogtreecommitdiffstats
path: root/packages/main/src/stores/__tests__/SharedStore.spec.ts
diff options
context:
space:
mode:
authorLibravatar Kristóf Marussy <kristof@marussy.com>2022-01-27 00:17:22 +0100
committerLibravatar Kristóf Marussy <kristof@marussy.com>2022-02-08 21:43:17 +0100
commit9546dc2aa39ab096ccc723786e718a739d0bdaf9 (patch)
tree9c3afc6155cc59f6dd1235397230aaa15a5f8cec /packages/main/src/stores/__tests__/SharedStore.spec.ts
parentrefactor: Apply shared store patches in batches (diff)
downloadsophie-9546dc2aa39ab096ccc723786e718a739d0bdaf9.tar.gz
sophie-9546dc2aa39ab096ccc723786e718a739d0bdaf9.tar.zst
sophie-9546dc2aa39ab096ccc723786e718a739d0bdaf9.zip
refactor: Coding conventions
Make sure that files have a default import with the same name as the file whenever possible to reduce surprise. Also shuffles around some file names for better legibility. Signed-off-by: Kristóf Marussy <kristof@marussy.com>
Diffstat (limited to 'packages/main/src/stores/__tests__/SharedStore.spec.ts')
-rw-r--r--packages/main/src/stores/__tests__/SharedStore.spec.ts4
1 files changed, 2 insertions, 2 deletions
diff --git a/packages/main/src/stores/__tests__/SharedStore.spec.ts b/packages/main/src/stores/__tests__/SharedStore.spec.ts
index 3ea187c..dfd59a1 100644
--- a/packages/main/src/stores/__tests__/SharedStore.spec.ts
+++ b/packages/main/src/stores/__tests__/SharedStore.spec.ts
@@ -20,7 +20,7 @@
20 20
21import type { ProfileConfig } from '../Profile'; 21import type { ProfileConfig } from '../Profile';
22import type { ServiceConfig } from '../Service'; 22import type { ServiceConfig } from '../Service';
23import { Config, sharedStore, SharedStore } from '../SharedStore'; 23import SharedStore, { Config } from '../SharedStore';
24 24
25const profileProps: ProfileConfig = { 25const profileProps: ProfileConfig = {
26 name: 'Test profile', 26 name: 'Test profile',
@@ -34,7 +34,7 @@ const serviceProps: ServiceConfig = {
34let sut: SharedStore; 34let sut: SharedStore;
35 35
36beforeEach(() => { 36beforeEach(() => {
37 sut = sharedStore.create(); 37 sut = SharedStore.create();
38}); 38});
39 39
40describe('loadConfig', () => { 40describe('loadConfig', () => {