aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/sway/meson.build b/sway/meson.build
index d92bb905..a9503c3b 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -153,10 +153,6 @@ sway_sources = files(
153 'tree/output.c', 153 'tree/output.c',
154) 154)
155 155
156if get_option('enable-xwayland')
157 sway_sources += 'desktop/xwayland.c'
158endif
159
160sway_deps = [ 156sway_deps = [
161 cairo, 157 cairo,
162 gdk_pixbuf, 158 gdk_pixbuf,
@@ -170,10 +166,14 @@ sway_deps = [
170 server_protos, 166 server_protos,
171 wayland_server, 167 wayland_server,
172 wlroots, 168 wlroots,
173 xcb,
174 xkbcommon, 169 xkbcommon,
175] 170]
176 171
172if get_option('enable-xwayland')
173 sway_sources += 'desktop/xwayland.c'
174 sway_deps += xcb
175endif
176
177executable( 177executable(
178 'sway', 178 'sway',
179 sway_sources, 179 sway_sources,