aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Michel Ganguin <michel@ganguin.net>2018-08-02 09:36:47 +0200
committerLibravatar emersion <contact@emersion.fr>2018-08-02 08:36:47 +0100
commitd6095588a143710d25be47577ea65517770e7a74 (patch)
tree7347f317f47a67dcc1ae20716948a59cd35f2bb3 /sway/meson.build
parentMerge pull request #2396 from RyanDwyer/fix-resize-wiggle (diff)
downloadsway-d6095588a143710d25be47577ea65517770e7a74.tar.gz
sway-d6095588a143710d25be47577ea65517770e7a74.tar.zst
sway-d6095588a143710d25be47577ea65517770e7a74.zip
Link xcb dependency to meson options "enable_xwayland" (#2393)
* Link xcb dependency to meson options "enable_xwayland" * Link xcb dependency to meson options "enable_xwayland"
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/sway/meson.build b/sway/meson.build
index d92bb905..a9503c3b 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -153,10 +153,6 @@ sway_sources = files(
153 'tree/output.c', 153 'tree/output.c',
154) 154)
155 155
156if get_option('enable-xwayland')
157 sway_sources += 'desktop/xwayland.c'
158endif
159
160sway_deps = [ 156sway_deps = [
161 cairo, 157 cairo,
162 gdk_pixbuf, 158 gdk_pixbuf,
@@ -170,10 +166,14 @@ sway_deps = [
170 server_protos, 166 server_protos,
171 wayland_server, 167 wayland_server,
172 wlroots, 168 wlroots,
173 xcb,
174 xkbcommon, 169 xkbcommon,
175] 170]
176 171
172if get_option('enable-xwayland')
173 sway_sources += 'desktop/xwayland.c'
174 sway_deps += xcb
175endif
176
177executable( 177executable(
178 'sway', 178 'sway',
179 sway_sources, 179 sway_sources,