aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Tony Crisci <tony@dubstepdish.com>2017-11-30 03:39:27 -0500
committerLibravatar Tony Crisci <tony@dubstepdish.com>2017-11-30 03:39:27 -0500
commit88cc7e31781a0d42bdd4f9eee646c02ff03857c4 (patch)
tree7cb3d493be3e01752e345bdba29ea3ba2842c4ae /meson.build
parentworking meson build (diff)
downloadsway-88cc7e31781a0d42bdd4f9eee646c02ff03857c4.tar.gz
sway-88cc7e31781a0d42bdd4f9eee646c02ff03857c4.tar.zst
sway-88cc7e31781a0d42bdd4f9eee646c02ff03857c4.zip
use meson subdirectories
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build35
1 files changed, 2 insertions, 33 deletions
diff --git a/meson.build b/meson.build
index 06eed97f..a28e1097 100644
--- a/meson.build
+++ b/meson.build
@@ -30,37 +30,6 @@ add_project_arguments('-DSWAY_VERSION="5"', language: 'c')
30 30
31sway_inc = include_directories('include') 31sway_inc = include_directories('include')
32 32
33sway_sources = [ 33subdir('common')
34 'sway/main.c', 34subdir('sway')
35 'sway/server.c',
36 'sway/commands.c',
37 'sway/commands/exit.c',
38 'sway/ipc-json.c',
39 'sway/ipc-server.c',
40 'sway/desktop/output.c',
41 'sway/desktop/xdg_shell_v6.c',
42 'sway/tree/container.c',
43 'sway/tree/layout.c',
44 'sway/tree/workspace.c',
45 'common/log.c',
46 'common/list.c',
47 'common/stringop.c',
48 'common/readline.c',
49 'common/ipc-client.c',
50]
51 35
52sway_deps = [
53 pixman,
54 wayland_server,
55 jsonc,
56 wlroots,
57 libcap,
58 math,
59]
60
61executable(
62 'sway',
63 sway_sources,
64 include_directories: [sway_inc],
65 dependencies: sway_deps
66)