aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Tony Crisci <tony@dubstepdish.com>2017-11-29 09:03:12 -0500
committerLibravatar Tony Crisci <tony@dubstepdish.com>2017-11-29 09:03:12 -0500
commitba6246ada199beafdc9c3585000bf9f59e4e91f8 (patch)
tree48c60502ebc0f1b251fac3209901bc9acc09e146 /meson.build
parentMerge pull request #1477 from acrisci/bug/set-mode (diff)
downloadsway-ba6246ada199beafdc9c3585000bf9f59e4e91f8.tar.gz
sway-ba6246ada199beafdc9c3585000bf9f59e4e91f8.tar.zst
sway-ba6246ada199beafdc9c3585000bf9f59e4e91f8.zip
working meson build
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build66
1 files changed, 66 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 00000000..06eed97f
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,66 @@
1project(
2 'sway',
3 'c',
4 license: 'MIT',
5 default_options: [
6 'c_std=c11',
7 'warning_level=2',
8 'werror=true',
9 ],
10)
11
12cc = meson.get_compiler('c')
13
14jsonc = dependency('json-c', version: '>=0.12.1')
15pcre = dependency('libpcre')
16wlroots = dependency('wlroots')
17wayland_server = dependency('wayland-server')
18wayland_client = dependency('wayland-client')
19wayland_egl = dependency('wayland-egl')
20wayland_protos = dependency('wayland-protocols')
21xkbcommon = dependency('xkbcommon')
22pango = dependency('pango')
23pixman = dependency('pixman-1')
24libcap = dependency('libcap')
25
26math = cc.find_library('m')
27
28# TODO version
29add_project_arguments('-DSWAY_VERSION="5"', language: 'c')
30
31sway_inc = include_directories('include')
32
33sway_sources = [
34 'sway/main.c',
35 'sway/server.c',
36 'sway/commands.c',
37 'sway/commands/exit.c',
38 'sway/ipc-json.c',
39 'sway/ipc-server.c',
40 'sway/desktop/output.c',
41 'sway/desktop/xdg_shell_v6.c',
42 'sway/tree/container.c',
43 'sway/tree/layout.c',
44 'sway/tree/workspace.c',
45 'common/log.c',
46 'common/list.c',
47 'common/stringop.c',
48 'common/readline.c',
49 'common/ipc-client.c',
50]
51
52sway_deps = [
53 pixman,
54 wayland_server,
55 jsonc,
56 wlroots,
57 libcap,
58 math,
59]
60
61executable(
62 'sway',
63 sway_sources,
64 include_directories: [sway_inc],
65 dependencies: sway_deps
66)