aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2022-09-27 05:17:12 -0300
committerLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2022-11-28 04:54:54 -0300
commit245e4cca6271355bf6be0dcc5ffb3d9bc359a4e9 (patch)
treed2796cbeb78cf8838c38fffa6a1df61605997f30 /configure.ac
parentconfigure*: remove extraneous blank lines (warning) (diff)
downloadfirejail-245e4cca6271355bf6be0dcc5ffb3d9bc359a4e9.tar.gz
firejail-245e4cca6271355bf6be0dcc5ffb3d9bc359a4e9.tar.zst
firejail-245e4cca6271355bf6be0dcc5ffb3d9bc359a4e9.zip
configure*: wrap long shell command output lines
Instead of binding them together with conditionals in a single line, split shell commands into multiple lines to make them more readable. Note that for the macro arguments in question, the content inside [] quotes is output literally into ./configure, so the commands can be written as if they were in a shell script directly (save for any special characters/tokens in Autoconf). Misc: Relates to commit 2c64d1fdd ("use AX_CHECK_COMPILE_FLAG to check for spectre flags", 2019-06-21).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 20 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index a78688e09..9cc20d94a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,22 +21,22 @@ AC_CONFIG_MACRO_DIR([m4])
21AC_PROG_CC 21AC_PROG_CC
22 22
23HAVE_SPECTRE="no" 23HAVE_SPECTRE="no"
24AX_CHECK_COMPILE_FLAG( 24AX_CHECK_COMPILE_FLAG([-mindirect-branch=thunk], [
25 [-mindirect-branch=thunk], 25 HAVE_SPECTRE="yes"
26 [HAVE_SPECTRE="yes" && EXTRA_CFLAGS="$EXTRA_CFLAGS -mindirect-branch=thunk"] 26 EXTRA_CFLAGS="$EXTRA_CFLAGS -mindirect-branch=thunk"
27) 27])
28AX_CHECK_COMPILE_FLAG( 28AX_CHECK_COMPILE_FLAG([-mretpoline], [
29 [-mretpoline], 29 HAVE_SPECTRE="yes"
30 [HAVE_SPECTRE="yes" && EXTRA_CFLAGS="$EXTRA_CFLAGS -mretpoline"] 30 EXTRA_CFLAGS="$EXTRA_CFLAGS -mretpoline"
31) 31])
32AX_CHECK_COMPILE_FLAG( 32AX_CHECK_COMPILE_FLAG([-fstack-clash-protection], [
33 [-fstack-clash-protection], 33 HAVE_SPECTRE="yes"
34 [HAVE_SPECTRE="yes" && EXTRA_CFLAGS="$EXTRA_CFLAGS -fstack-clash-protection"] 34 EXTRA_CFLAGS="$EXTRA_CFLAGS -fstack-clash-protection"
35) 35])
36AX_CHECK_COMPILE_FLAG( 36AX_CHECK_COMPILE_FLAG([-fstack-protector-strong], [
37 [-fstack-protector-strong], 37 HAVE_SPECTRE="yes"
38 [HAVE_SPECTRE="yes" && EXTRA_CFLAGS="$EXTRA_CFLAGS -fstack-protector-strong"] 38 EXTRA_CFLAGS="$EXTRA_CFLAGS -fstack-protector-strong"
39) 39])
40 40
41AC_ARG_ENABLE([analyzer], 41AC_ARG_ENABLE([analyzer],
42 [AS_HELP_STRING([--enable-analyzer], [enable GCC static analyzer])]) 42 [AS_HELP_STRING([--enable-analyzer], [enable GCC static analyzer])])
@@ -68,8 +68,10 @@ AC_ARG_ENABLE([apparmor],
68 [AS_HELP_STRING([--enable-apparmor], [enable apparmor])]) 68 [AS_HELP_STRING([--enable-apparmor], [enable apparmor])])
69AS_IF([test "x$enable_apparmor" = "xyes"], [ 69AS_IF([test "x$enable_apparmor" = "xyes"], [
70 HAVE_APPARMOR="-DHAVE_APPARMOR" 70 HAVE_APPARMOR="-DHAVE_APPARMOR"
71 PKG_CHECK_MODULES([AA], [libapparmor], 71 PKG_CHECK_MODULES([AA], [libapparmor], [
72 [EXTRA_CFLAGS="$EXTRA_CFLAGS $AA_CFLAGS" && EXTRA_LDFLAGS="$EXTRA_LDFLAGS $AA_LIBS"]) 72 EXTRA_CFLAGS="$EXTRA_CFLAGS $AA_CFLAGS"
73 EXTRA_LDFLAGS="$EXTRA_LDFLAGS $AA_LIBS"
74 ])
73]) 75])
74 76
75HAVE_SELINUX="" 77HAVE_SELINUX=""