aboutsummaryrefslogtreecommitdiffstats
path: root/wayland/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'wayland/CMakeLists.txt')
-rw-r--r--wayland/CMakeLists.txt32
1 files changed, 0 insertions, 32 deletions
diff --git a/wayland/CMakeLists.txt b/wayland/CMakeLists.txt
deleted file mode 100644
index 91fd7fff..00000000
--- a/wayland/CMakeLists.txt
+++ /dev/null
@@ -1,32 +0,0 @@
1include_directories(
2 ${PROTOCOLS_INCLUDE_DIRS}
3 ${PANGO_INCLUDE_DIRS}
4 ${XKBCOMMON_INCLUDE_DIRS}
5 ${WAYLAND_INCLUDE_DIR}
6 ${EPOLLSHIM_INCLUDE_DIRS}
7)
8
9add_library(sway-wayland STATIC
10 buffers.c
11 pango.c
12 registry.c
13 window.c
14 cairo.c
15 )
16
17target_link_libraries(sway-wayland
18 sway-common
19 sway-protocols
20 ${PANGO_LIBRARIES}
21 ${XKBCOMMON_LIBRARIES}
22 ${EPOLLSHIM_LIBRARIES}
23 )
24
25if (WITH_GDK_PIXBUF)
26 include_directories(
27 ${GDK_PIXBUF_INCLUDE_DIRS}
28 )
29 target_link_libraries(sway-wayland
30 ${GDK_PIXBUF_LIBRARIES}
31 )
32endif()