summaryrefslogtreecommitdiffstats
path: root/swaylock/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swaylock/meson.build')
-rw-r--r--swaylock/meson.build50
1 files changed, 31 insertions, 19 deletions
diff --git a/swaylock/meson.build b/swaylock/meson.build
index 675b8c69..6c87d173 100644
--- a/swaylock/meson.build
+++ b/swaylock/meson.build
@@ -1,25 +1,37 @@
1sysconfdir = get_option('sysconfdir') 1sysconfdir = get_option('sysconfdir')
2 2
3executable( 3dependencies = [
4 'swaylock', [ 4 cairo,
5 'main.c', 5 client_protos,
6 'password.c', 6 gdk_pixbuf,
7 'render.c', 7 math,
8 'seat.c' 8 pango,
9 ], 9 pangocairo,
10 xkbcommon,
11 wayland_client,
12 wlroots,
13]
14
15sources = [
16 'main.c',
17 'password.c',
18 'render.c',
19 'seat.c'
20]
21
22if libpam.found()
23 sources += ['pam.c']
24 dependencies += [libpam]
25else
26 warning('The swaylock binary must be setuid when compiled without libpam')
27 warning('You must do this manually post-install: chmod a+s /path/to/swaylock')
28 sources += ['shadow.c']
29endif
30
31executable('swaylock',
32 sources,
10 include_directories: [sway_inc], 33 include_directories: [sway_inc],
11 dependencies: [ 34 dependencies: dependencies,
12 cairo,
13 client_protos,
14 gdk_pixbuf,
15 libpam,
16 math,
17 pango,
18 pangocairo,
19 xkbcommon,
20 wayland_client,
21 wlroots,
22 ],
23 link_with: [lib_sway_common, lib_sway_client], 35 link_with: [lib_sway_common, lib_sway_client],
24 install: true 36 install: true
25) 37)