aboutsummaryrefslogtreecommitdiffstats
path: root/swayidle/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swayidle/meson.build')
-rw-r--r--swayidle/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/swayidle/meson.build b/swayidle/meson.build
new file mode 100644
index 00000000..09c482d6
--- /dev/null
+++ b/swayidle/meson.build
@@ -0,0 +1,17 @@
1threads = dependency('threads')
2
3executable(
4 'swayidle', [
5 'main.c',
6 ],
7 include_directories: [sway_inc],
8 dependencies: [
9 client_protos,
10 wayland_client,
11 wayland_server,
12 wlroots,
13 swayidle_deps,
14 ],
15 link_with: [lib_sway_common, lib_sway_client],
16 install: true
17)