aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 9ff3f05f..30c848e2 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -7,11 +7,14 @@ sway_sources = files(
7 'debug-tree.c', 7 'debug-tree.c',
8 'ipc-json.c', 8 'ipc-json.c',
9 'ipc-server.c', 9 'ipc-server.c',
10 'scratchpad.c',
10 'security.c', 11 'security.c',
11 12
12 'desktop/desktop.c', 13 'desktop/desktop.c',
14 'desktop/idle_inhibit_v1.c',
13 'desktop/layer_shell.c', 15 'desktop/layer_shell.c',
14 'desktop/output.c', 16 'desktop/output.c',
17 'desktop/render.c',
15 'desktop/transaction.c', 18 'desktop/transaction.c',
16 'desktop/xdg_shell_v6.c', 19 'desktop/xdg_shell_v6.c',
17 'desktop/xdg_shell.c', 20 'desktop/xdg_shell.c',
@@ -33,16 +36,20 @@ sway_sources = files(
33 'commands/border.c', 36 'commands/border.c',
34 'commands/client.c', 37 'commands/client.c',
35 'commands/default_border.c', 38 'commands/default_border.c',
39 'commands/default_floating_border.c',
36 'commands/default_orientation.c', 40 'commands/default_orientation.c',
37 'commands/exit.c', 41 'commands/exit.c',
38 'commands/exec.c', 42 'commands/exec.c',
39 'commands/exec_always.c', 43 'commands/exec_always.c',
40 'commands/floating.c', 44 'commands/floating.c',
45 'commands/floating_minmax_size.c',
46 'commands/floating_modifier.c',
41 'commands/focus.c', 47 'commands/focus.c',
42 'commands/focus_follows_mouse.c', 48 'commands/focus_follows_mouse.c',
43 'commands/focus_wrapping.c', 49 'commands/focus_wrapping.c',
44 'commands/font.c', 50 'commands/font.c',
45 'commands/for_window.c', 51 'commands/for_window.c',
52 'commands/force_display_urgency_hint.c',
46 'commands/force_focus_wrapping.c', 53 'commands/force_focus_wrapping.c',
47 'commands/fullscreen.c', 54 'commands/fullscreen.c',
48 'commands/gaps.c', 55 'commands/gaps.c',
@@ -56,10 +63,12 @@ sway_sources = files(
56 'commands/mode.c', 63 'commands/mode.c',
57 'commands/mouse_warping.c', 64 'commands/mouse_warping.c',
58 'commands/move.c', 65 'commands/move.c',
66 'commands/no_focus.c',
59 'commands/output.c', 67 'commands/output.c',
60 'commands/reload.c', 68 'commands/reload.c',
61 'commands/rename.c', 69 'commands/rename.c',
62 'commands/resize.c', 70 'commands/resize.c',
71 'commands/scratchpad.c',
63 'commands/seat.c', 72 'commands/seat.c',
64 'commands/seat/attach.c', 73 'commands/seat/attach.c',
65 'commands/seat/cursor.c', 74 'commands/seat/cursor.c',
@@ -73,6 +82,7 @@ sway_sources = files(
73 'commands/swap.c', 82 'commands/swap.c',
74 'commands/title_format.c', 83 'commands/title_format.c',
75 'commands/unmark.c', 84 'commands/unmark.c',
85 'commands/urgent.c',
76 'commands/workspace.c', 86 'commands/workspace.c',
77 'commands/workspace_layout.c', 87 'commands/workspace_layout.c',
78 'commands/ws_auto_back_and_forth.c', 88 'commands/ws_auto_back_and_forth.c',
@@ -115,8 +125,10 @@ sway_sources = files(
115 'commands/input/pointer_accel.c', 125 'commands/input/pointer_accel.c',
116 'commands/input/repeat_delay.c', 126 'commands/input/repeat_delay.c',
117 'commands/input/repeat_rate.c', 127 'commands/input/repeat_rate.c',
128 'commands/input/scroll_button.c',
118 'commands/input/scroll_method.c', 129 'commands/input/scroll_method.c',
119 'commands/input/tap.c', 130 'commands/input/tap.c',
131 'commands/input/tap_button_map.c',
120 'commands/input/xkb_layout.c', 132 'commands/input/xkb_layout.c',
121 'commands/input/xkb_model.c', 133 'commands/input/xkb_model.c',
122 'commands/input/xkb_options.c', 134 'commands/input/xkb_options.c',