aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build25
1 files changed, 17 insertions, 8 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 6762ef2d..d937e425 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -8,24 +8,23 @@ sway_sources = files(
8 'lock.c', 8 'lock.c',
9 'main.c', 9 'main.c',
10 'realtime.c', 10 'realtime.c',
11 'scene_descriptor.c',
11 'server.c', 12 'server.c',
13 'sway_text_node.c',
12 'swaynag.c', 14 'swaynag.c',
13 'xdg_activation_v1.c', 15 'xdg_activation_v1.c',
14 'xdg_decoration.c', 16 'xdg_decoration.c',
15 17
16 'desktop/desktop.c',
17 'desktop/idle_inhibit_v1.c', 18 'desktop/idle_inhibit_v1.c',
18 'desktop/layer_shell.c', 19 'desktop/layer_shell.c',
19 'desktop/output.c', 20 'desktop/output.c',
20 'desktop/render.c',
21 'desktop/surface.c',
22 'desktop/transaction.c', 21 'desktop/transaction.c',
23 'desktop/xdg_shell.c', 22 'desktop/xdg_shell.c',
23 'desktop/launcher.c',
24 24
25 'input/input-manager.c', 25 'input/input-manager.c',
26 'input/cursor.c', 26 'input/cursor.c',
27 'input/keyboard.c', 27 'input/keyboard.c',
28 'input/libinput.c',
29 'input/seat.c', 28 'input/seat.c',
30 'input/seatop_default.c', 29 'input/seatop_default.c',
31 'input/seatop_down.c', 30 'input/seatop_down.c',
@@ -67,6 +66,7 @@ sway_sources = files(
67 'commands/force_focus_wrapping.c', 66 'commands/force_focus_wrapping.c',
68 'commands/fullscreen.c', 67 'commands/fullscreen.c',
69 'commands/gaps.c', 68 'commands/gaps.c',
69 'commands/gesture.c',
70 'commands/hide_edge_borders.c', 70 'commands/hide_edge_borders.c',
71 'commands/inhibit_idle.c', 71 'commands/inhibit_idle.c',
72 'commands/kill.c', 72 'commands/kill.c',
@@ -85,6 +85,7 @@ sway_sources = files(
85 'commands/nop.c', 85 'commands/nop.c',
86 'commands/output.c', 86 'commands/output.c',
87 'commands/popup_during_fullscreen.c', 87 'commands/popup_during_fullscreen.c',
88 'commands/primary_selection.c',
88 'commands/reload.c', 89 'commands/reload.c',
89 'commands/rename.c', 90 'commands/rename.c',
90 'commands/resize.c', 91 'commands/resize.c',
@@ -156,6 +157,7 @@ sway_sources = files(
156 'commands/input/drag.c', 157 'commands/input/drag.c',
157 'commands/input/drag_lock.c', 158 'commands/input/drag_lock.c',
158 'commands/input/dwt.c', 159 'commands/input/dwt.c',
160 'commands/input/dwtp.c',
159 'commands/input/events.c', 161 'commands/input/events.c',
160 'commands/input/left_handed.c', 162 'commands/input/left_handed.c',
161 'commands/input/map_from_region.c', 163 'commands/input/map_from_region.c',
@@ -164,9 +166,11 @@ sway_sources = files(
164 'commands/input/middle_emulation.c', 166 'commands/input/middle_emulation.c',
165 'commands/input/natural_scroll.c', 167 'commands/input/natural_scroll.c',
166 'commands/input/pointer_accel.c', 168 'commands/input/pointer_accel.c',
169 'commands/input/rotation_angle.c',
167 'commands/input/repeat_delay.c', 170 'commands/input/repeat_delay.c',
168 'commands/input/repeat_rate.c', 171 'commands/input/repeat_rate.c',
169 'commands/input/scroll_button.c', 172 'commands/input/scroll_button.c',
173 'commands/input/scroll_button_lock.c',
170 'commands/input/scroll_factor.c', 174 'commands/input/scroll_factor.c',
171 'commands/input/scroll_method.c', 175 'commands/input/scroll_method.c',
172 'commands/input/tap.c', 176 'commands/input/tap.c',
@@ -190,12 +194,14 @@ sway_sources = files(
190 'commands/output/max_render_time.c', 194 'commands/output/max_render_time.c',
191 'commands/output/mode.c', 195 'commands/output/mode.c',
192 'commands/output/position.c', 196 'commands/output/position.c',
197 'commands/output/power.c',
193 'commands/output/render_bit_depth.c', 198 'commands/output/render_bit_depth.c',
194 'commands/output/scale.c', 199 'commands/output/scale.c',
195 'commands/output/scale_filter.c', 200 'commands/output/scale_filter.c',
196 'commands/output/subpixel.c', 201 'commands/output/subpixel.c',
197 'commands/output/toggle.c', 202 'commands/output/toggle.c',
198 'commands/output/transform.c', 203 'commands/output/transform.c',
204 'commands/output/unplug.c',
199 205
200 'tree/arrange.c', 206 'tree/arrange.c',
201 'tree/container.c', 207 'tree/container.c',
@@ -216,23 +222,26 @@ sway_deps = [
216 math, 222 math,
217 pango, 223 pango,
218 pcre2, 224 pcre2,
219 glesv2,
220 pixman, 225 pixman,
221 server_protos, 226 threads,
222 wayland_server, 227 wayland_server,
223 wlroots, 228 wlroots,
224 xkbcommon, 229 xkbcommon,
230 xcb,
225 xcb_icccm, 231 xcb_icccm,
226] 232]
227 233
228if have_xwayland 234if have_xwayland
229 sway_sources += 'desktop/xwayland.c' 235 sway_sources += 'desktop/xwayland.c'
230 sway_deps += xcb 236endif
237
238if wlroots_features['libinput_backend']
239 sway_sources += 'input/libinput.c'
231endif 240endif
232 241
233executable( 242executable(
234 'sway', 243 'sway',
235 sway_sources, 244 sway_sources + wl_protos_src,
236 include_directories: [sway_inc], 245 include_directories: [sway_inc],
237 dependencies: sway_deps, 246 dependencies: sway_deps,
238 link_with: [lib_sway_common], 247 link_with: [lib_sway_common],