aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build31
1 files changed, 22 insertions, 9 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 1402db15..d937e425 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -5,25 +5,26 @@ sway_sources = files(
5 'decoration.c', 5 'decoration.c',
6 'ipc-json.c', 6 'ipc-json.c',
7 'ipc-server.c', 7 'ipc-server.c',
8 'lock.c',
8 'main.c', 9 'main.c',
10 'realtime.c',
11 'scene_descriptor.c',
9 'server.c', 12 'server.c',
13 'sway_text_node.c',
10 'swaynag.c', 14 'swaynag.c',
11 'xdg_activation_v1.c', 15 'xdg_activation_v1.c',
12 'xdg_decoration.c', 16 'xdg_decoration.c',
13 17
14 'desktop/desktop.c',
15 'desktop/idle_inhibit_v1.c', 18 'desktop/idle_inhibit_v1.c',
16 'desktop/layer_shell.c', 19 'desktop/layer_shell.c',
17 'desktop/output.c', 20 'desktop/output.c',
18 'desktop/render.c',
19 'desktop/surface.c',
20 'desktop/transaction.c', 21 'desktop/transaction.c',
21 'desktop/xdg_shell.c', 22 'desktop/xdg_shell.c',
23 'desktop/launcher.c',
22 24
23 'input/input-manager.c', 25 'input/input-manager.c',
24 'input/cursor.c', 26 'input/cursor.c',
25 'input/keyboard.c', 27 'input/keyboard.c',
26 'input/libinput.c',
27 'input/seat.c', 28 'input/seat.c',
28 'input/seatop_default.c', 29 'input/seatop_default.c',
29 'input/seatop_down.c', 30 'input/seatop_down.c',
@@ -65,6 +66,7 @@ sway_sources = files(
65 'commands/force_focus_wrapping.c', 66 'commands/force_focus_wrapping.c',
66 'commands/fullscreen.c', 67 'commands/fullscreen.c',
67 'commands/gaps.c', 68 'commands/gaps.c',
69 'commands/gesture.c',
68 'commands/hide_edge_borders.c', 70 'commands/hide_edge_borders.c',
69 'commands/inhibit_idle.c', 71 'commands/inhibit_idle.c',
70 'commands/kill.c', 72 'commands/kill.c',
@@ -83,6 +85,7 @@ sway_sources = files(
83 'commands/nop.c', 85 'commands/nop.c',
84 'commands/output.c', 86 'commands/output.c',
85 'commands/popup_during_fullscreen.c', 87 'commands/popup_during_fullscreen.c',
88 'commands/primary_selection.c',
86 'commands/reload.c', 89 'commands/reload.c',
87 'commands/rename.c', 90 'commands/rename.c',
88 'commands/resize.c', 91 'commands/resize.c',
@@ -154,6 +157,7 @@ sway_sources = files(
154 'commands/input/drag.c', 157 'commands/input/drag.c',
155 'commands/input/drag_lock.c', 158 'commands/input/drag_lock.c',
156 'commands/input/dwt.c', 159 'commands/input/dwt.c',
160 'commands/input/dwtp.c',
157 'commands/input/events.c', 161 'commands/input/events.c',
158 'commands/input/left_handed.c', 162 'commands/input/left_handed.c',
159 'commands/input/map_from_region.c', 163 'commands/input/map_from_region.c',
@@ -162,9 +166,11 @@ sway_sources = files(
162 'commands/input/middle_emulation.c', 166 'commands/input/middle_emulation.c',
163 'commands/input/natural_scroll.c', 167 'commands/input/natural_scroll.c',
164 'commands/input/pointer_accel.c', 168 'commands/input/pointer_accel.c',
169 'commands/input/rotation_angle.c',
165 'commands/input/repeat_delay.c', 170 'commands/input/repeat_delay.c',
166 'commands/input/repeat_rate.c', 171 'commands/input/repeat_rate.c',
167 'commands/input/scroll_button.c', 172 'commands/input/scroll_button.c',
173 'commands/input/scroll_button_lock.c',
168 'commands/input/scroll_factor.c', 174 'commands/input/scroll_factor.c',
169 'commands/input/scroll_method.c', 175 'commands/input/scroll_method.c',
170 'commands/input/tap.c', 176 'commands/input/tap.c',
@@ -188,11 +194,14 @@ sway_sources = files(
188 'commands/output/max_render_time.c', 194 'commands/output/max_render_time.c',
189 'commands/output/mode.c', 195 'commands/output/mode.c',
190 'commands/output/position.c', 196 'commands/output/position.c',
197 'commands/output/power.c',
198 'commands/output/render_bit_depth.c',
191 'commands/output/scale.c', 199 'commands/output/scale.c',
192 'commands/output/scale_filter.c', 200 'commands/output/scale_filter.c',
193 'commands/output/subpixel.c', 201 'commands/output/subpixel.c',
194 'commands/output/toggle.c', 202 'commands/output/toggle.c',
195 'commands/output/transform.c', 203 'commands/output/transform.c',
204 'commands/output/unplug.c',
196 205
197 'tree/arrange.c', 206 'tree/arrange.c',
198 'tree/container.c', 207 'tree/container.c',
@@ -212,23 +221,27 @@ sway_deps = [
212 libudev, 221 libudev,
213 math, 222 math,
214 pango, 223 pango,
215 pcre, 224 pcre2,
216 glesv2,
217 pixman, 225 pixman,
218 server_protos, 226 threads,
219 wayland_server, 227 wayland_server,
220 wlroots, 228 wlroots,
221 xkbcommon, 229 xkbcommon,
230 xcb,
231 xcb_icccm,
222] 232]
223 233
224if have_xwayland 234if have_xwayland
225 sway_sources += 'desktop/xwayland.c' 235 sway_sources += 'desktop/xwayland.c'
226 sway_deps += xcb 236endif
237
238if wlroots_features['libinput_backend']
239 sway_sources += 'input/libinput.c'
227endif 240endif
228 241
229executable( 242executable(
230 'sway', 243 'sway',
231 sway_sources, 244 sway_sources + wl_protos_src,
232 include_directories: [sway_inc], 245 include_directories: [sway_inc],
233 dependencies: sway_deps, 246 dependencies: sway_deps,
234 link_with: [lib_sway_common], 247 link_with: [lib_sway_common],