aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build22
1 files changed, 14 insertions, 8 deletions
diff --git a/sway/meson.build b/sway/meson.build
index ced7419c..d937e425 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -8,24 +8,23 @@ sway_sources = files(
8 'lock.c', 8 'lock.c',
9 'main.c', 9 'main.c',
10 'realtime.c', 10 'realtime.c',
11 'scene_descriptor.c',
11 'server.c', 12 'server.c',
13 'sway_text_node.c',
12 'swaynag.c', 14 'swaynag.c',
13 'xdg_activation_v1.c', 15 'xdg_activation_v1.c',
14 'xdg_decoration.c', 16 'xdg_decoration.c',
15 17
16 'desktop/desktop.c',
17 'desktop/idle_inhibit_v1.c', 18 'desktop/idle_inhibit_v1.c',
18 'desktop/layer_shell.c', 19 'desktop/layer_shell.c',
19 'desktop/output.c', 20 'desktop/output.c',
20 'desktop/render.c',
21 'desktop/surface.c',
22 'desktop/transaction.c', 21 'desktop/transaction.c',
23 'desktop/xdg_shell.c', 22 'desktop/xdg_shell.c',
23 'desktop/launcher.c',
24 24
25 'input/input-manager.c', 25 'input/input-manager.c',
26 'input/cursor.c', 26 'input/cursor.c',
27 'input/keyboard.c', 27 'input/keyboard.c',
28 'input/libinput.c',
29 'input/seat.c', 28 'input/seat.c',
30 'input/seatop_default.c', 29 'input/seatop_default.c',
31 'input/seatop_down.c', 30 'input/seatop_down.c',
@@ -86,6 +85,7 @@ sway_sources = files(
86 'commands/nop.c', 85 'commands/nop.c',
87 'commands/output.c', 86 'commands/output.c',
88 'commands/popup_during_fullscreen.c', 87 'commands/popup_during_fullscreen.c',
88 'commands/primary_selection.c',
89 'commands/reload.c', 89 'commands/reload.c',
90 'commands/rename.c', 90 'commands/rename.c',
91 'commands/resize.c', 91 'commands/resize.c',
@@ -157,6 +157,7 @@ sway_sources = files(
157 'commands/input/drag.c', 157 'commands/input/drag.c',
158 'commands/input/drag_lock.c', 158 'commands/input/drag_lock.c',
159 'commands/input/dwt.c', 159 'commands/input/dwt.c',
160 'commands/input/dwtp.c',
160 'commands/input/events.c', 161 'commands/input/events.c',
161 'commands/input/left_handed.c', 162 'commands/input/left_handed.c',
162 'commands/input/map_from_region.c', 163 'commands/input/map_from_region.c',
@@ -165,9 +166,11 @@ sway_sources = files(
165 'commands/input/middle_emulation.c', 166 'commands/input/middle_emulation.c',
166 'commands/input/natural_scroll.c', 167 'commands/input/natural_scroll.c',
167 'commands/input/pointer_accel.c', 168 'commands/input/pointer_accel.c',
169 'commands/input/rotation_angle.c',
168 'commands/input/repeat_delay.c', 170 'commands/input/repeat_delay.c',
169 'commands/input/repeat_rate.c', 171 'commands/input/repeat_rate.c',
170 'commands/input/scroll_button.c', 172 'commands/input/scroll_button.c',
173 'commands/input/scroll_button_lock.c',
171 'commands/input/scroll_factor.c', 174 'commands/input/scroll_factor.c',
172 'commands/input/scroll_method.c', 175 'commands/input/scroll_method.c',
173 'commands/input/tap.c', 176 'commands/input/tap.c',
@@ -198,6 +201,7 @@ sway_sources = files(
198 'commands/output/subpixel.c', 201 'commands/output/subpixel.c',
199 'commands/output/toggle.c', 202 'commands/output/toggle.c',
200 'commands/output/transform.c', 203 'commands/output/transform.c',
204 'commands/output/unplug.c',
201 205
202 'tree/arrange.c', 206 'tree/arrange.c',
203 'tree/container.c', 207 'tree/container.c',
@@ -218,24 +222,26 @@ sway_deps = [
218 math, 222 math,
219 pango, 223 pango,
220 pcre2, 224 pcre2,
221 glesv2,
222 pixman, 225 pixman,
223 server_protos,
224 threads, 226 threads,
225 wayland_server, 227 wayland_server,
226 wlroots, 228 wlroots,
227 xkbcommon, 229 xkbcommon,
230 xcb,
228 xcb_icccm, 231 xcb_icccm,
229] 232]
230 233
231if have_xwayland 234if have_xwayland
232 sway_sources += 'desktop/xwayland.c' 235 sway_sources += 'desktop/xwayland.c'
233 sway_deps += xcb 236endif
237
238if wlroots_features['libinput_backend']
239 sway_sources += 'input/libinput.c'
234endif 240endif
235 241
236executable( 242executable(
237 'sway', 243 'sway',
238 sway_sources, 244 sway_sources + wl_protos_src,
239 include_directories: [sway_inc], 245 include_directories: [sway_inc],
240 dependencies: sway_deps, 246 dependencies: sway_deps,
241 link_with: [lib_sway_common], 247 link_with: [lib_sway_common],