aboutsummaryrefslogtreecommitdiffstats
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index 4532a6c3..448335cc 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -74,7 +74,7 @@ function(add_config name source destination)
74 add_custom_command( 74 add_custom_command(
75 OUTPUT ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name} 75 OUTPUT ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name}
76 COMMAND sed -r 76 COMMAND sed -r
77 's?__PREFIX__?${CMAKE_INSTALL_PREFIX}?g\; s?__SYSCONFDIR__?${CMAKE_INSTALL_FULL_SYSCONFDIR}?g' 77 's?__PREFIX__?${CMAKE_INSTALL_PREFIX}?g\; s?__SYSCONFDIR__?${CMAKE_INSTALL_FULL_SYSCONFDIR}?g\; s?__DATADIR__?${CMAKE_INSTALL_FULL_DATADIR}?g'
78 ${PROJECT_SOURCE_DIR}/${source}.in > ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name} 78 ${PROJECT_SOURCE_DIR}/${source}.in > ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name}
79 DEPENDS ${PROJECT_SOURCE_DIR}/${source}.in 79 DEPENDS ${PROJECT_SOURCE_DIR}/${source}.in
80 COMMENT "Generating config file ${source}" 80 COMMENT "Generating config file ${source}"