aboutsummaryrefslogtreecommitdiffstats
path: root/protocols/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/CMakeLists.txt')
-rw-r--r--protocols/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/protocols/CMakeLists.txt b/protocols/CMakeLists.txt
index ff0a2e4d..a9b459ab 100644
--- a/protocols/CMakeLists.txt
+++ b/protocols/CMakeLists.txt
@@ -22,12 +22,18 @@ WAYLAND_ADD_PROTOCOL_SERVER(proto-server-swaylock
22 swaylock 22 swaylock
23) 23)
24 24
25WAYLAND_ADD_PROTOCOL_SERVER(proto-server-gamma-control
26 gamma-control.xml
27 gamma-control
28)
29
25add_library(sway-protocols STATIC 30add_library(sway-protocols STATIC
26 ${proto-client-xdg-shell} 31 ${proto-client-xdg-shell}
27 ${proto-client-desktop-shell} 32 ${proto-client-desktop-shell}
28 ${proto-server-desktop-shell} 33 ${proto-server-desktop-shell}
29 ${proto-client-swaylock} 34 ${proto-client-swaylock}
30 ${proto-server-swaylock} 35 ${proto-server-swaylock}
36 ${proto-server-gamma-control}
31 ) 37 )
32 38
33set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE) 39set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE)