aboutsummaryrefslogtreecommitdiffstats
path: root/protocols/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/CMakeLists.txt')
-rw-r--r--protocols/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/protocols/CMakeLists.txt b/protocols/CMakeLists.txt
index 07becc36..d7516d0c 100644
--- a/protocols/CMakeLists.txt
+++ b/protocols/CMakeLists.txt
@@ -13,10 +13,21 @@ WAYLAND_ADD_PROTOCOL_SERVER(proto-server-desktop-shell
13 desktop-shell 13 desktop-shell
14) 14)
15 15
16WAYLAND_ADD_PROTOCOL_CLIENT(proto-client-swaylock
17 swaylock.xml
18 swaylock
19)
20WAYLAND_ADD_PROTOCOL_SERVER(proto-server-swaylock
21 swaylock.xml
22 swaylock
23)
24
16add_library(sway-protocols 25add_library(sway-protocols
17 ${proto-client-xdg-shell} 26 ${proto-client-xdg-shell}
18 ${proto-client-desktop-shell} 27 ${proto-client-desktop-shell}
19 ${proto-server-desktop-shell} 28 ${proto-server-desktop-shell}
29 ${proto-client-swaylock}
30 ${proto-server-swaylock}
20 ) 31 )
21 32
22set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE) 33set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE)