aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9842d78a..38a55678 100644
--- a/meson.build
+++ b/meson.build
@@ -104,8 +104,12 @@ if get_option('sd-bus-provider') == 'auto'
104 sdbus = dependency('libelogind', 104 sdbus = dependency('libelogind',
105 required: false, 105 required: false,
106 version: '>=239', 106 version: '>=239',
107 not_found_message: 'libelogind not found, trying basu',
107 ) 108 )
108 endif 109 endif
110 if not sdbus.found()
111 sdbus = dependency('basu', required: false)
112 endif
109else 113else
110 sdbus = dependency(get_option('sd-bus-provider'), required: get_option('tray')) 114 sdbus = dependency(get_option('sd-bus-provider'), required: get_option('tray'))
111endif 115endif
@@ -122,6 +126,7 @@ conf_data.set10('HAVE_XWAYLAND', have_xwayland)
122conf_data.set10('HAVE_GDK_PIXBUF', gdk_pixbuf.found()) 126conf_data.set10('HAVE_GDK_PIXBUF', gdk_pixbuf.found())
123conf_data.set10('HAVE_LIBSYSTEMD', sdbus.found() and sdbus.name() == 'libsystemd') 127conf_data.set10('HAVE_LIBSYSTEMD', sdbus.found() and sdbus.name() == 'libsystemd')
124conf_data.set10('HAVE_LIBELOGIND', sdbus.found() and sdbus.name() == 'libelogind') 128conf_data.set10('HAVE_LIBELOGIND', sdbus.found() and sdbus.name() == 'libelogind')
129conf_data.set10('HAVE_BASU', sdbus.found() and sdbus.name() == 'basu')
125conf_data.set10('HAVE_TRAY', have_tray) 130conf_data.set10('HAVE_TRAY', have_tray)
126 131
127scdoc = dependency('scdoc', version: '>=1.9.2', native: true, required: get_option('man-pages')) 132scdoc = dependency('scdoc', version: '>=1.9.2', native: true, required: get_option('man-pages'))