aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a1f406ec..b943236f 100644
--- a/meson.build
+++ b/meson.build
@@ -20,6 +20,8 @@ datadir = get_option('datadir')
20sysconfdir = get_option('sysconfdir') 20sysconfdir = get_option('sysconfdir')
21prefix = get_option('prefix') 21prefix = get_option('prefix')
22 22
23swayidle_deps = []
24
23jsonc = dependency('json-c', version: '>=0.13') 25jsonc = dependency('json-c', version: '>=0.13')
24pcre = dependency('libpcre') 26pcre = dependency('libpcre')
25wlroots = dependency('wlroots', fallback: ['wlroots', 'wlroots']) 27wlroots = dependency('wlroots', fallback: ['wlroots', 'wlroots'])
@@ -37,6 +39,8 @@ pixman = dependency('pixman-1')
37libcap = dependency('libcap') 39libcap = dependency('libcap')
38libinput = dependency('libinput', version: '>=1.6.0') 40libinput = dependency('libinput', version: '>=1.6.0')
39libpam = cc.find_library('pam') 41libpam = cc.find_library('pam')
42systemd = dependency('libsystemd', required: false)
43elogind = dependency('libelogind', required: false)
40math = cc.find_library('m') 44math = cc.find_library('m')
41rt = cc.find_library('rt') 45rt = cc.find_library('rt')
42git = find_program('git', required: false) 46git = find_program('git', required: false)
@@ -47,6 +51,16 @@ if gdk_pixbuf.found()
47 conf_data.set('HAVE_GDK_PIXBUF', true) 51 conf_data.set('HAVE_GDK_PIXBUF', true)
48endif 52endif
49 53
54if systemd.found()
55 conf_data.set('SWAY_IDLE_HAS_SYSTEMD', true)
56 swayidle_deps += systemd
57endif
58
59if elogind.found()
60 conf_data.set('SWAY_IDLE_HAS_ELOGIND', true)
61 swayidle_deps += elogind
62endif
63
50scdoc = find_program('scdoc', required: false) 64scdoc = find_program('scdoc', required: false)
51 65
52if scdoc.found() 66if scdoc.found()
@@ -59,6 +73,7 @@ if scdoc.found()
59 'sway/sway-input.5.scd', 73 'sway/sway-input.5.scd',
60 'swaylock/swaylock.1.scd', 74 'swaylock/swaylock.1.scd',
61 'swaymsg/swaymsg.1.scd', 75 'swaymsg/swaymsg.1.scd',
76 'swayidle/swayidle.1.scd',
62 ] 77 ]
63 foreach filename : man_files 78 foreach filename : man_files
64 topic = filename.split('.')[-3].split('/')[-1] 79 topic = filename.split('.')[-3].split('/')[-1]
@@ -106,6 +121,7 @@ subdir('client')
106subdir('swaybg') 121subdir('swaybg')
107subdir('swaybar') 122subdir('swaybar')
108subdir('swaylock') 123subdir('swaylock')
124subdir('swayidle')
109 125
110config = configuration_data() 126config = configuration_data()
111config.set('sysconfdir', join_paths(prefix, sysconfdir)) 127config.set('sysconfdir', join_paths(prefix, sysconfdir))