aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 6f2681af..af383fbf 100644
--- a/meson.build
+++ b/meson.build
@@ -24,8 +24,11 @@ pixman = dependency('pixman-1')
24libcap = dependency('libcap') 24libcap = dependency('libcap')
25math = cc.find_library('m') 25math = cc.find_library('m')
26 26
27# TODO version 27git_commit_hash = run_command(['git', 'describe', '--always', '--tags']).stdout().strip()
28add_project_arguments('-DSWAY_VERSION="5"', language: 'c') 28git_branch = run_command(['git', 'rev-parse', '--abbrev-ref', 'HEAD']).stdout().strip()
29version = '"@0@ (" __DATE__ ", branch \'@1@\')"'.format(git_commit_hash, git_branch)
30
31add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c')
29 32
30sway_inc = include_directories('include') 33sway_inc = include_directories('include')
31 34