aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2336a148..cfd77ce7 100644
--- a/meson.build
+++ b/meson.build
@@ -60,7 +60,11 @@ rt = cc.find_library('rt')
60git = find_program('git', required: false) 60git = find_program('git', required: false)
61 61
62# Try first to find wlroots as a subproject, then as a system dependency 62# Try first to find wlroots as a subproject, then as a system dependency
63wlroots_proj = subproject('wlroots', required: false) 63wlroots_proj = subproject(
64 'wlroots',
65 default_options: ['rootston=disabled', 'examples=disabled'],
66 required: false,
67)
64if wlroots_proj.found() 68if wlroots_proj.found()
65 wlroots = wlroots_proj.get_variable('wlroots') 69 wlroots = wlroots_proj.get_variable('wlroots')
66 wlroots_conf = wlroots_proj.get_variable('conf_data') 70 wlroots_conf = wlroots_proj.get_variable('conf_data')