aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 57dbea02..bd20ca99 100644
--- a/meson.build
+++ b/meson.build
@@ -19,12 +19,13 @@ is_freebsd = host_machine.system().startswith('freebsd')
19datadir = get_option('datadir') 19datadir = get_option('datadir')
20sysconfdir = get_option('sysconfdir') 20sysconfdir = get_option('sysconfdir')
21prefix = get_option('prefix') 21prefix = get_option('prefix')
22instlibdir = get_option('instlibdir') 22libexecdir = get_option('libexecdir')
23 23
24if instlibdir == '' 24if libexecdir == ''
25 instlibdir = join_paths(prefix, 'lib/sway') 25 libexecdir = 'lib'
26endif 26endif
27add_project_arguments('-DINSTLIBDIR="/@0@"'.format(instlibdir), language : 'c') 27sway_libexecdir = join_paths(prefix, libexecdir, 'sway')
28add_project_arguments('-DSWAY_LIBEXECDIR="/@0@"'.format(sway_libexecdir), language : 'c')
28 29
29 30
30jsonc = dependency('json-c', version: '>=0.13') 31jsonc = dependency('json-c', version: '>=0.13')