summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build23
1 files changed, 18 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index aaffc41f..3ba1e0c3 100644
--- a/meson.build
+++ b/meson.build
@@ -95,11 +95,6 @@ conf_data.set10('HAVE_SYSTEMD', systemd.found())
95conf_data.set10('HAVE_ELOGIND', elogind.found()) 95conf_data.set10('HAVE_ELOGIND', elogind.found())
96conf_data.set10('HAVE_TRAY', have_tray) 96conf_data.set10('HAVE_TRAY', have_tray)
97 97
98if not systemd.found() and not elogind.found()
99 warning('The sway binary must be setuid when compiled without (e)logind')
100 warning('You must do this manually post-install: chmod a+s /path/to/sway')
101endif
102
103scdoc = find_program('scdoc', required: get_option('man-pages')) 98scdoc = find_program('scdoc', required: get_option('man-pages'))
104if scdoc.found() 99if scdoc.found()
105 sh = find_program('sh') 100 sh = find_program('sh')
@@ -237,3 +232,21 @@ if get_option('fish-completions')
237 232
238 install_data(fish_files, install_dir: fish_install_dir) 233 install_data(fish_files, install_dir: fish_install_dir)
239endif 234endif
235
236status = [
237 '',
238 'Features:',
239 'xwayland: @0@'.format(have_xwayland),
240 'gdk-pixbuf: @0@'.format(gdk_pixbuf.found()),
241 'systemd: @0@'.format(systemd.found()),
242 'elogind: @0@'.format(elogind.found()),
243 'tray: @0@'.format(have_tray),
244 'man-pages: @0@'.format(scdoc.found()),
245 '',
246]
247message('\n'.join(status))
248
249if not systemd.found() and not elogind.found()
250 warning('The sway binary must be setuid when compiled without (e)logind')
251 warning('You must do this manually post-install: chmod a+s /path/to/sway')
252endif