aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 34098eb3..b53670b6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,7 +116,8 @@ add_subdirectory(wayland)
116add_subdirectory(sway) 116add_subdirectory(sway)
117if(enable-swaybg) 117if(enable-swaybg)
118 if(CAIRO_FOUND AND PANGO_FOUND) 118 if(CAIRO_FOUND AND PANGO_FOUND)
119 add_subdirectory(swaybg) 119 # TODO WLR
120 #add_subdirectory(swaybg)
120 else() 121 else()
121 message(WARNING "Not building swaybg - cairo, and pango are required.") 122 message(WARNING "Not building swaybg - cairo, and pango are required.")
122 endif() 123 endif()
@@ -125,18 +126,21 @@ if(enable-swaymsg)
125 add_subdirectory(swaymsg) 126 add_subdirectory(swaymsg)
126endif() 127endif()
127if(enable-swaygrab) 128if(enable-swaygrab)
128 add_subdirectory(swaygrab) 129 # TODO WLR
130 #add_subdirectory(swaygrab)
129endif() 131endif()
130if(enable-swaybar) 132if(enable-swaybar)
131 if(CAIRO_FOUND AND PANGO_FOUND) 133 if(CAIRO_FOUND AND PANGO_FOUND)
132 add_subdirectory(swaybar) 134 # TODO WLR
135 #add_subdirectory(swaybar)
133 else() 136 else()
134 message(WARNING "Not building swaybar - cairo, and pango are required.") 137 message(WARNING "Not building swaybar - cairo, and pango are required.")
135 endif() 138 endif()
136endif() 139endif()
137if(enable-swaylock) 140if(enable-swaylock)
138 if(CAIRO_FOUND AND PANGO_FOUND AND PAM_FOUND) 141 if(CAIRO_FOUND AND PANGO_FOUND AND PAM_FOUND)
139 add_subdirectory(swaylock) 142 # TODO WLR
143 #add_subdirectory(swaylock)
140 else() 144 else()
141 message(WARNING "Not building swaylock - cairo, pango, and PAM are required.") 145 message(WARNING "Not building swaylock - cairo, pango, and PAM are required.")
142 endif() 146 endif()