aboutsummaryrefslogtreecommitdiffstats
path: root/swaylock/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-04-02 22:48:13 -0400
committerLibravatar Drew DeVault <sir@cmpwn.com>2018-04-04 18:47:48 -0400
commitb32bf595aeae7f8ac68354e45a80c0438374ec17 (patch)
treeb93185d2ac4b7081b9d0651eaaadeae21de48929 /swaylock/meson.build
parentMove swaybg background rendering into common/ (diff)
downloadsway-b32bf595aeae7f8ac68354e45a80c0438374ec17.tar.gz
sway-b32bf595aeae7f8ac68354e45a80c0438374ec17.tar.zst
sway-b32bf595aeae7f8ac68354e45a80c0438374ec17.zip
Initial swaylock port
Diffstat (limited to 'swaylock/meson.build')
-rw-r--r--swaylock/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/swaylock/meson.build b/swaylock/meson.build
new file mode 100644
index 00000000..5b886ded
--- /dev/null
+++ b/swaylock/meson.build
@@ -0,0 +1,18 @@
1executable(
2 'swaylock',
3 'main.c',
4 include_directories: [sway_inc],
5 dependencies: [
6 cairo,
7 client_protos,
8 gdk_pixbuf,
9 libpam,
10 math,
11 pango,
12 pangocairo,
13 wayland_client,
14 wlroots,
15 ],
16 link_with: [lib_sway_common, lib_sway_client],
17 install: true
18)