summaryrefslogtreecommitdiffstats
path: root/swayidle/meson.build
diff options
context:
space:
mode:
authorLibravatar emersion <contact@emersion.fr>2018-11-18 00:33:06 +0100
committerLibravatar emersion <contact@emersion.fr>2018-11-18 00:33:06 +0100
commitcad851805bea6b4777685df1c6adf8cb9fa71835 (patch)
tree145fcb048cc3df3d04a8b6afb90de68dd2dd80a9 /swayidle/meson.build
parentMerge pull request #3142 from RyanDwyer/move-view-properties (diff)
downloadsway-cad851805bea6b4777685df1c6adf8cb9fa71835.tar.gz
sway-cad851805bea6b4777685df1c6adf8cb9fa71835.tar.zst
sway-cad851805bea6b4777685df1c6adf8cb9fa71835.zip
Use #if instead of #ifdef
Diffstat (limited to 'swayidle/meson.build')
-rw-r--r--swayidle/meson.build24
1 files changed, 16 insertions, 8 deletions
diff --git a/swayidle/meson.build b/swayidle/meson.build
index 6c3ac119..79d2c5c4 100644
--- a/swayidle/meson.build
+++ b/swayidle/meson.build
@@ -1,18 +1,26 @@
1threads = dependency('threads') 1threads = dependency('threads')
2 2
3swayidle_deps = [
4 client_protos,
5 pixman,
6 wayland_client,
7 wayland_server,
8 wlroots,
9]
10
11if systemd.found()
12 swayidle_deps += systemd
13endif
14if elogind.found()
15 swayidle_deps += elogind
16endif
17
3executable( 18executable(
4 'swayidle', [ 19 'swayidle', [
5 'main.c', 20 'main.c',
6 ], 21 ],
7 include_directories: [sway_inc], 22 include_directories: [sway_inc],
8 dependencies: [ 23 dependencies: swayidle_deps,
9 client_protos,
10 pixman,
11 wayland_client,
12 wayland_server,
13 wlroots,
14 swayidle_deps,
15 ],
16 link_with: [lib_sway_common, lib_sway_client], 24 link_with: [lib_sway_common, lib_sway_client],
17 install_rpath : rpathdir, 25 install_rpath : rpathdir,
18 install: true 26 install: true