aboutsummaryrefslogtreecommitdiffstats
path: root/swaygrab/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2015-12-01 15:25:41 -0500
committerLibravatar Drew DeVault <sir@cmpwn.com>2015-12-01 15:25:41 -0500
commit1fbabc6c747205e62cd1dff3771bd319a935438f (patch)
tree8c079c9fe0f909be8429ab010ed75853bd3429d0 /swaygrab/CMakeLists.txt
parentMerge pull request #286 from mikkeloscar/wlc-origin-point (diff)
parentcmake: remove unnecessary quotes (diff)
downloadsway-1fbabc6c747205e62cd1dff3771bd319a935438f.tar.gz
sway-1fbabc6c747205e62cd1dff3771bd319a935438f.tar.zst
sway-1fbabc6c747205e62cd1dff3771bd319a935438f.zip
Merge pull request #285 from christophgysin/cmake
cmake configuration cleanup
Diffstat (limited to 'swaygrab/CMakeLists.txt')
-rw-r--r--swaygrab/CMakeLists.txt22
1 files changed, 12 insertions, 10 deletions
diff --git a/swaygrab/CMakeLists.txt b/swaygrab/CMakeLists.txt
index 8bc8ed8b..efe8986b 100644
--- a/swaygrab/CMakeLists.txt
+++ b/swaygrab/CMakeLists.txt
@@ -1,18 +1,20 @@
1project(swaygrab) 1project(swaygrab)
2 2
3set(CMAKE_CURRENT_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/../bin/) 3file(GLOB sources ${PROJECT_SOURCE_DIR}/*.c)
4 4file(GLOB common ${PROJECT_SOURCE_DIR}/../common/*.c)
5FILE(GLOB sources ${PROJECT_SOURCE_DIR}/*.c)
6FILE(GLOB common ${PROJECT_SOURCE_DIR}/../common/*.c)
7 5
8add_executable(swaygrab 6add_executable(swaygrab
9 ${sources} 7 ${sources}
10 ${common} 8 ${common}
11) 9)
12 10
13TARGET_LINK_LIBRARIES(swaygrab rt) 11target_link_libraries(swaygrab
12 rt
13)
14 14
15install( 15install(
16 TARGETS swaygrab 16 TARGETS swaygrab
17 RUNTIME DESTINATION bin 17 RUNTIME
18 COMPONENT runtime) 18 DESTINATION bin
19 COMPONENT runtime
20)