aboutsummaryrefslogtreecommitdiffstats
path: root/swaybar/meson.build
diff options
context:
space:
mode:
authorLibravatar Ian Fan <ianfan0@gmail.com>2018-10-28 10:25:47 +0000
committerLibravatar Ian Fan <ianfan0@gmail.com>2018-12-31 20:40:18 +0000
commit5f65f339896fadf0011b75d78c869594876d35d9 (patch)
treebbb234ad123657f1a8ed1f311cf9183b67e7e961 /swaybar/meson.build
parentswaybar: remove old tray implementation (diff)
downloadsway-5f65f339896fadf0011b75d78c869594876d35d9.tar.gz
sway-5f65f339896fadf0011b75d78c869594876d35d9.tar.zst
sway-5f65f339896fadf0011b75d78c869594876d35d9.zip
swaybar: add tray interface
Diffstat (limited to 'swaybar/meson.build')
-rw-r--r--swaybar/meson.build40
1 files changed, 27 insertions, 13 deletions
diff --git a/swaybar/meson.build b/swaybar/meson.build
index c27cf2c2..b83f47e5 100644
--- a/swaybar/meson.build
+++ b/swaybar/meson.build
@@ -1,3 +1,28 @@
1tray_files = get_option('enable-tray') ? [
2 'tray/tray.c',
3] : []
4
5swaybar_deps = [
6 cairo,
7 client_protos,
8 gdk_pixbuf,
9 jsonc,
10 math,
11 pango,
12 pangocairo,
13 rt,
14 wayland_client,
15 wayland_cursor,
16 wlroots,
17]
18if get_option('enable-tray')
19 if systemd.found()
20 swaybar_deps += systemd
21 elif elogind.found()
22 swaybar_deps += elogind
23 endif
24endif
25
1executable( 26executable(
2 'swaybar', [ 27 'swaybar', [
3 'bar.c', 28 'bar.c',
@@ -8,21 +33,10 @@ executable(
8 'main.c', 33 'main.c',
9 'render.c', 34 'render.c',
10 'status_line.c', 35 'status_line.c',
36 tray_files
11 ], 37 ],
12 include_directories: [sway_inc], 38 include_directories: [sway_inc],
13 dependencies: [ 39 dependencies: swaybar_deps,
14 cairo,
15 client_protos,
16 gdk_pixbuf,
17 jsonc,
18 math,
19 pango,
20 pangocairo,
21 rt,
22 wayland_client,
23 wayland_cursor,
24 wlroots,
25 ],
26 link_with: [lib_sway_common, lib_sway_client], 40 link_with: [lib_sway_common, lib_sway_client],
27 install_rpath : rpathdir, 41 install_rpath : rpathdir,
28 install: true 42 install: true