aboutsummaryrefslogtreecommitdiffstats
path: root/swaybar/meson.build
diff options
context:
space:
mode:
authorLibravatar Ryan Dwyer <ryandwyer1@gmail.com>2018-10-13 16:04:37 +1000
committerLibravatar Ryan Dwyer <ryandwyer1@gmail.com>2018-10-15 00:26:27 +1000
commit4056c09e13c1aeead6dd4085fc7e263a17a0b195 (patch)
treea3413f2a5717968e370d68521b689580d5adc5a0 /swaybar/meson.build
parentDocument `border csd` (diff)
downloadsway-4056c09e13c1aeead6dd4085fc7e263a17a0b195.tar.gz
sway-4056c09e13c1aeead6dd4085fc7e263a17a0b195.tar.zst
sway-4056c09e13c1aeead6dd4085fc7e263a17a0b195.zip
Move swaybar's event loop to common directory and refactor
* The loop functions are now prefixed with `loop_`. * It is now easy to add timers to the loop. * Timers are implemented using pollfd and timerfd, rather than manually checking them when any other event happens to arrive.
Diffstat (limited to 'swaybar/meson.build')
-rw-r--r--swaybar/meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/swaybar/meson.build b/swaybar/meson.build
index 7a02a33f..0c116172 100644
--- a/swaybar/meson.build
+++ b/swaybar/meson.build
@@ -2,7 +2,6 @@ executable(
2 'swaybar', [ 2 'swaybar', [
3 'bar.c', 3 'bar.c',
4 'config.c', 4 'config.c',
5 'event_loop.c',
6 'i3bar.c', 5 'i3bar.c',
7 'ipc.c', 6 'ipc.c',
8 'main.c', 7 'main.c',