aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-04-04 21:32:31 -0400
committerLibravatar Drew DeVault <sir@cmpwn.com>2018-04-05 00:03:20 -0400
commitf77986338fc4186d003908012685c12d718ed647 (patch)
treef8b1ec4af069ab2123453d713251dcd7c51767d1 /sway/meson.build
parentMerge pull request #1732 from emersion/view-children (diff)
downloadsway-f77986338fc4186d003908012685c12d718ed647.tar.gz
sway-f77986338fc4186d003908012685c12d718ed647.tar.zst
sway-f77986338fc4186d003908012685c12d718ed647.zip
Implement resize command
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build46
1 files changed, 27 insertions, 19 deletions
diff --git a/sway/meson.build b/sway/meson.build
index f210c195..ec7b4c42 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -2,10 +2,28 @@ sway_sources = files(
2 'main.c', 2 'main.c',
3 'server.c', 3 'server.c',
4 'commands.c', 4 'commands.c',
5 'config.c',
6 'criteria.c',
7 'ipc-json.c',
8 'ipc-server.c',
9 'security.c',
10
11 'desktop/output.c',
12 'desktop/layer_shell.c',
13 'desktop/wl_shell.c',
14 'desktop/xdg_shell_v6.c',
15 'desktop/xwayland.c',
16
5 'input/input-manager.c', 17 'input/input-manager.c',
6 'input/seat.c', 18 'input/seat.c',
7 'input/cursor.c', 19 'input/cursor.c',
8 'input/keyboard.c', 20 'input/keyboard.c',
21
22 'config/bar.c',
23 'config/output.c',
24 'config/seat.c',
25 'config/input.c',
26
9 'commands/bar.c', 27 'commands/bar.c',
10 'commands/bind.c', 28 'commands/bind.c',
11 'commands/default_orientation.c', 29 'commands/default_orientation.c',
@@ -20,13 +38,19 @@ sway_sources = files(
20 'commands/input.c', 38 'commands/input.c',
21 'commands/layout.c', 39 'commands/layout.c',
22 'commands/mode.c', 40 'commands/mode.c',
23 'commands/split.c', 41 'commands/mouse_warping.c',
24 'commands/move.c', 42 'commands/move.c',
43 'commands/output.c',
44 'commands/reload.c',
45 'commands/resize.c',
25 'commands/seat.c', 46 'commands/seat.c',
26 'commands/seat/attach.c', 47 'commands/seat/attach.c',
27 'commands/seat/fallback.c', 48 'commands/seat/fallback.c',
28 'commands/set.c', 49 'commands/set.c',
50 'commands/split.c',
29 'commands/swaybg_command.c', 51 'commands/swaybg_command.c',
52 'commands/workspace.c',
53
30 'commands/bar/activate_button.c', 54 'commands/bar/activate_button.c',
31 'commands/bar/binding_mode_indicator.c', 55 'commands/bar/binding_mode_indicator.c',
32 'commands/bar/bindsym.c', 56 'commands/bar/bindsym.c',
@@ -51,6 +75,7 @@ sway_sources = files(
51 'commands/bar/tray_padding.c', 75 'commands/bar/tray_padding.c',
52 'commands/bar/workspace_buttons.c', 76 'commands/bar/workspace_buttons.c',
53 'commands/bar/wrap_scroll.c', 77 'commands/bar/wrap_scroll.c',
78
54 'commands/input/accel_profile.c', 79 'commands/input/accel_profile.c',
55 'commands/input/click_method.c', 80 'commands/input/click_method.c',
56 'commands/input/drag_lock.c', 81 'commands/input/drag_lock.c',
@@ -67,24 +92,7 @@ sway_sources = files(
67 'commands/input/xkb_options.c', 92 'commands/input/xkb_options.c',
68 'commands/input/xkb_rules.c', 93 'commands/input/xkb_rules.c',
69 'commands/input/xkb_variant.c', 94 'commands/input/xkb_variant.c',
70 'commands/mouse_warping.c', 95
71 'commands/output.c',
72 'commands/reload.c',
73 'commands/workspace.c',
74 'config.c',
75 'config/bar.c',
76 'config/output.c',
77 'config/seat.c',
78 'config/input.c',
79 'criteria.c',
80 'ipc-json.c',
81 'ipc-server.c',
82 'desktop/output.c',
83 'desktop/layer_shell.c',
84 'desktop/wl_shell.c',
85 'desktop/xdg_shell_v6.c',
86 'desktop/xwayland.c',
87 'security.c',
88 'tree/container.c', 96 'tree/container.c',
89 'tree/layout.c', 97 'tree/layout.c',
90 'tree/view.c', 98 'tree/view.c',