aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Arkadiusz Hiler <arek@hiler.eu>2018-09-30 15:11:24 +0300
committerLibravatar Arkadiusz Hiler <arek@hiler.eu>2018-09-30 15:37:01 +0300
commiteed0bc3ebd15bf94a28ca019ab656a3a0bc0d258 (patch)
tree63e09dad69399fe4470830b3103301a97ce0ab7f /sway/meson.build
parentMerge pull request #2726 from RyanDwyer/overhaul-gaps (diff)
downloadsway-eed0bc3ebd15bf94a28ca019ab656a3a0bc0d258.tar.gz
sway-eed0bc3ebd15bf94a28ca019ab656a3a0bc0d258.tar.zst
sway-eed0bc3ebd15bf94a28ca019ab656a3a0bc0d258.zip
Add support for installing binaries with DT_RPATH
It's better to use DT_RPATH dynamic section of the elf binary to store the paths of libraries to load instead of overwriting LD_LIBRARY_PATH for the whole environment, causing surprises. This solution is much more transparent and perfectly suitable for running contained installations of wayland/wlroots/sway. The code unsetting the LD_LIBRARY_PATH/LD_PRELOAD was also deleted as it's a placebo security at best - we should trust the execution path that leads us to running sway, and it's way too late to care about those variables since we already started executing our compositor, thus we would be compromised anyway.
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
index b6394ecb..6eb9a9d7 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -187,5 +187,6 @@ executable(
187 include_directories: [sway_inc], 187 include_directories: [sway_inc],
188 dependencies: sway_deps, 188 dependencies: sway_deps,
189 link_with: [lib_sway_common], 189 link_with: [lib_sway_common],
190 install_rpath : rpathdir,
190 install: true 191 install: true
191) 192)