aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Brian Ashworth <bosrsf04@gmail.com>2019-01-31 22:58:52 -0500
committerLibravatar Brian Ashworth <bosrsf04@gmail.com>2019-01-31 22:58:52 -0500
commitebe5399ed6bfa59f5f5d289bf3d46b08f60787b3 (patch)
treeca0bff9d26283b0fa790855e7379e8da2e89166b /sway/meson.build
parentRebase #1636 against current master (diff)
downloadsway-ebe5399ed6bfa59f5f5d289bf3d46b08f60787b3.tar.gz
sway-ebe5399ed6bfa59f5f5d289bf3d46b08f60787b3.tar.zst
sway-ebe5399ed6bfa59f5f5d289bf3d46b08f60787b3.zip
pointer_constraint: change to a seat subcommand
This changes the `pointer_constraint` command to be a subcommand of seat to allow for per-seat settings. The current implementation that is not a seat subcommand will only operate on the current seat and will segfault in the config due to `config->handler_context.seat` only being set at runtime. This also allows for the wildcard identifier to be used to alter the pointer constraint settings on all seats and allows for the setting to be merged with the rest of the seat config.
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/sway/meson.build b/sway/meson.build
index b3837e21..293a4ed2 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -75,7 +75,6 @@ sway_sources = files(
75 'commands/nop.c', 75 'commands/nop.c',
76 'commands/output.c', 76 'commands/output.c',
77 'commands/popup_during_fullscreen.c', 77 'commands/popup_during_fullscreen.c',
78 'commands/pointer_constraint.c',
79 'commands/reload.c', 78 'commands/reload.c',
80 'commands/rename.c', 79 'commands/rename.c',
81 'commands/resize.c', 80 'commands/resize.c',
@@ -85,6 +84,7 @@ sway_sources = files(
85 'commands/seat/cursor.c', 84 'commands/seat/cursor.c',
86 'commands/seat/fallback.c', 85 'commands/seat/fallback.c',
87 'commands/seat/hide_cursor.c', 86 'commands/seat/hide_cursor.c',
87 'commands/seat/pointer_constraint.c',
88 'commands/set.c', 88 'commands/set.c',
89 'commands/show_marks.c', 89 'commands/show_marks.c',
90 'commands/smart_borders.c', 90 'commands/smart_borders.c',