aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Simon Ser <contact@emersion.fr>2022-11-26 20:18:43 +0100
committerLibravatar Simon Zeni <simon@bl4ckb0ne.ca>2022-11-28 13:28:15 -0500
commite62299daa45de139b912325eb5800796586e57c7 (patch)
tree5a1972d97bd65000f8e328667f2a772c8622e9e8 /sway/meson.build
parentMake session optional (diff)
downloadsway-e62299daa45de139b912325eb5800796586e57c7.tar.gz
sway-e62299daa45de139b912325eb5800796586e57c7.tar.zst
sway-e62299daa45de139b912325eb5800796586e57c7.zip
Make libinput backend optional
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 8a73cc86..de10e14f 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -26,7 +26,6 @@ sway_sources = files(
26 'input/input-manager.c', 26 'input/input-manager.c',
27 'input/cursor.c', 27 'input/cursor.c',
28 'input/keyboard.c', 28 'input/keyboard.c',
29 'input/libinput.c',
30 'input/seat.c', 29 'input/seat.c',
31 'input/seatop_default.c', 30 'input/seatop_default.c',
32 'input/seatop_down.c', 31 'input/seatop_down.c',
@@ -227,12 +226,16 @@ sway_deps = [
227 wayland_server, 226 wayland_server,
228 wlroots, 227 wlroots,
229 xkbcommon, 228 xkbcommon,
229 xcb,
230 xcb_icccm, 230 xcb_icccm,
231] 231]
232 232
233if have_xwayland 233if have_xwayland
234 sway_sources += 'desktop/xwayland.c' 234 sway_sources += 'desktop/xwayland.c'
235 sway_deps += xcb 235endif
236
237if wlroots_features['libinput_backend']
238 sway_sources += 'input/libinput.c'
236endif 239endif
237 240
238executable( 241executable(