aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Brian Ashworth <bosrsf04@gmail.com>2019-03-24 21:21:24 -0400
committerLibravatar Drew DeVault <sir@cmpwn.com>2019-03-24 19:26:12 -0600
commitd9de5b87583ccf8b633980ebbdec67227bbe7db4 (patch)
tree4084a568e8b28e2e37142b8a293e00f619d48e17 /sway/meson.build
parentFix #3924 (diff)
downloadsway-d9de5b87583ccf8b633980ebbdec67227bbe7db4.tar.gz
sway-d9de5b87583ccf8b633980ebbdec67227bbe7db4.tar.zst
sway-d9de5b87583ccf8b633980ebbdec67227bbe7db4.zip
Implement inhibit_idle command
This implements the following command to set/unset a user idle inhibitor for a view: `inhibit_idle focus|fullscreen|open|none|visible` The modes are as follows: - focus: inhibited when the view is focused by any seat - fullscreen: inhibited when the view is fullscreen (or a descendant of a fullscreen container) and is visible on any output - open: inhibited until the view is closed or the inhibitor is unset or changed - none: unsets any user set idle inhibitors for the view - visible: inhibited when the view is visible on any output This should have no effect on idle inhibitors set by the applications themselves and those should still work as intended. Since this operates on the view in the handler context, it is possible to set it on the currently focused view, on any existing view with criteria, or for any future view with for_window.
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 9f79fb6c..12b86efb 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -63,6 +63,7 @@ sway_sources = files(
63 'commands/fullscreen.c', 63 'commands/fullscreen.c',
64 'commands/gaps.c', 64 'commands/gaps.c',
65 'commands/hide_edge_borders.c', 65 'commands/hide_edge_borders.c',
66 'commands/inhibit_idle.c',
66 'commands/kill.c', 67 'commands/kill.c',
67 'commands/mark.c', 68 'commands/mark.c',
68 'commands/opacity.c', 69 'commands/opacity.c',