aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Ryan Dwyer <ryandwyer1@gmail.com>2018-07-18 16:13:28 +1000
committerLibravatar Ryan Dwyer <ryandwyer1@gmail.com>2018-07-22 23:10:19 +1000
commit9fbe13b9be18c732b58033a57a22a299af91a170 (patch)
treea24901c1bb4eff87877c0d9fb96767b662a9d533 /sway/meson.build
parentMerge pull request #2320 from RedSoxFan/reset-outputs-on-reload (diff)
downloadsway-9fbe13b9be18c732b58033a57a22a299af91a170.tar.gz
sway-9fbe13b9be18c732b58033a57a22a299af91a170.tar.zst
sway-9fbe13b9be18c732b58033a57a22a299af91a170.zip
Implement floating_modifier and mouse operations for floating views
This implements the following: * `floating_modifier` configuration directive * Drag a floating window by its title bar * Hold mod + drag a floating window from anywhere * Resize a floating view by dragging the border * Resize a floating view by holding mod and right clicking anywhere on the view * Resize a floating view and keep aspect ratio by holding shift while resizing using either method * Mouse cursor turns into resize when hovering floating border or corner
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 09bc40b8..f4fdc8ea 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -42,6 +42,7 @@ sway_sources = files(
42 'commands/exec_always.c', 42 'commands/exec_always.c',
43 'commands/floating.c', 43 'commands/floating.c',
44 'commands/floating_minmax_size.c', 44 'commands/floating_minmax_size.c',
45 'commands/floating_modifier.c',
45 'commands/focus.c', 46 'commands/focus.c',
46 'commands/focus_follows_mouse.c', 47 'commands/focus_follows_mouse.c',
47 'commands/focus_wrapping.c', 48 'commands/focus_wrapping.c',