aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Tony Crisci <tony@dubstepdish.com>2017-11-30 03:39:27 -0500
committerLibravatar Tony Crisci <tony@dubstepdish.com>2017-11-30 03:39:27 -0500
commit88cc7e31781a0d42bdd4f9eee646c02ff03857c4 (patch)
tree7cb3d493be3e01752e345bdba29ea3ba2842c4ae /sway/meson.build
parentworking meson build (diff)
downloadsway-88cc7e31781a0d42bdd4f9eee646c02ff03857c4.tar.gz
sway-88cc7e31781a0d42bdd4f9eee646c02ff03857c4.tar.zst
sway-88cc7e31781a0d42bdd4f9eee646c02ff03857c4.zip
use meson subdirectories
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
new file mode 100644
index 00000000..1f17ed31
--- /dev/null
+++ b/sway/meson.build
@@ -0,0 +1,29 @@
1sway_sources = sway_common + files(
2 'main.c',
3 'server.c',
4 'commands.c',
5 'commands/exit.c',
6 'ipc-json.c',
7 'ipc-server.c',
8 'desktop/output.c',
9 'desktop/xdg_shell_v6.c',
10 'tree/container.c',
11 'tree/layout.c',
12 'tree/workspace.c',
13)
14
15sway_deps = [
16 pixman,
17 wayland_server,
18 jsonc,
19 wlroots,
20 libcap,
21 math,
22]
23
24executable(
25 'sway',
26 sway_sources,
27 include_directories: [sway_inc],
28 dependencies: sway_deps
29)