aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Ryan Dwyer <ryandwyer1@gmail.com>2018-10-07 20:40:05 +1000
committerLibravatar Ryan Dwyer <ryandwyer1@gmail.com>2018-10-08 22:49:59 +1000
commit832ebc896655cb5ca7689559d4e42b426d764e71 (patch)
tree1a3bc3ff7fb13d7ed5e86ad67a05739d4c4a1de3 /sway/meson.build
parentMerge pull request #2791 from RyanDwyer/status-command-optional (diff)
downloadsway-832ebc896655cb5ca7689559d4e42b426d764e71.tar.gz
sway-832ebc896655cb5ca7689559d4e42b426d764e71.tar.zst
sway-832ebc896655cb5ca7689559d4e42b426d764e71.zip
Implement popup_during_fullscreen
This introduces a new view_impl function: is_transient_for. Similar to container_has_ancestor but works using the surface parents rather than the tree. This patch modifies view_is_visible, container_at and so on to allow transient views to function normally when they're in front of a fullscreen view.
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 8ab28869..c7fc9697 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -70,6 +70,7 @@ sway_sources = files(
70 'commands/no_focus.c', 70 'commands/no_focus.c',
71 'commands/nop.c', 71 'commands/nop.c',
72 'commands/output.c', 72 'commands/output.c',
73 'commands/popup_during_fullscreen.c',
73 'commands/reload.c', 74 'commands/reload.c',
74 'commands/rename.c', 75 'commands/rename.c',
75 'commands/resize.c', 76 'commands/resize.c',