aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Brian Ashworth <bosrsf04@gmail.com>2019-11-03 14:20:05 -0500
committerLibravatar Drew DeVault <sir@cmpwn.com>2019-11-21 10:42:10 -0500
commit5d882cb5fc2d9d9fd68439021e48a90aa2e50e79 (patch)
treec519449aebb2fa15406407eee5af3cd4164e1b62 /sway/meson.build
parentinput_cmd_xkb_file: allow shell path expansion (diff)
downloadsway-5d882cb5fc2d9d9fd68439021e48a90aa2e50e79.tar.gz
sway-5d882cb5fc2d9d9fd68439021e48a90aa2e50e79.tar.zst
sway-5d882cb5fc2d9d9fd68439021e48a90aa2e50e79.zip
Add support for wlr_keyboard_group
A wlr_keyboard_group allows for multiple keyboard devices to be combined into one logical keyboard. This is useful for keyboards that are split into multiple input devices despite appearing as one physical keyboard in the user's mind. This adds support for wlr_keyboard_groups to sway. There are two keyboard groupings currently supported, which can be set on a per-seat basis. The first keyboard grouping is none, which disables all grouping and provides no functional change. The second is keymap, which groups the keyboard devices in the seat by their keymap. With this grouping, the effective layout and repeat info is also synced across keyboard devices in the seat. Device specific bindings will still be executed as normal, but everything else related to key and modifier events will be handled by the keyboard group's keyboard.
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
index e285c09e..5458d3dc 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -91,6 +91,7 @@ sway_sources = files(
91 'commands/seat/cursor.c', 91 'commands/seat/cursor.c',
92 'commands/seat/fallback.c', 92 'commands/seat/fallback.c',
93 'commands/seat/hide_cursor.c', 93 'commands/seat/hide_cursor.c',
94 'commands/seat/keyboard_grouping.c',
94 'commands/seat/pointer_constraint.c', 95 'commands/seat/pointer_constraint.c',
95 'commands/seat/xcursor_theme.c', 96 'commands/seat/xcursor_theme.c',
96 'commands/set.c', 97 'commands/set.c',