aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Brian Ashworth <bosrsf04@gmail.com>2019-01-10 12:43:10 -0500
committerLibravatar Brian Ashworth <bosrsf04@gmail.com>2019-01-10 12:43:10 -0500
commit3d6440ec26f2b39c54fd03aa3a3c822a8a2bbc72 (patch)
tree05e5dddd092b3d3ba16166a3784a49923e9f3de2 /sway/meson.build
parentMerge pull request #3400 from ianyfan/config-brace (diff)
downloadsway-3d6440ec26f2b39c54fd03aa3a3c822a8a2bbc72.tar.gz
sway-3d6440ec26f2b39c54fd03aa3a3c822a8a2bbc72.tar.zst
sway-3d6440ec26f2b39c54fd03aa3a3c822a8a2bbc72.zip
bar_cmd_bind: utilize mouse button helpers
This modifies `bar_cmd_bindsym` to use `get_mouse_bindsym` for parsing mouse buttons. This also introduces `cmd_bar_bindcode`, which will use `get_mouse_bindcode` for parsing mouse buttons. Like sway bindings, the two commands are encapsulated in a single file with shared code. This also modifies swaybar to operate off of event codes rather than x11 button numbers, which allows for any mouse button to be used. This introduces two new IPC properties: - For `get_bar_config`, `event_code` has been added to the `bindings` section and will include to event code for the button. If the event code can be mapped to a x11 button, `input_code` will still be the x11 button number. Otherwise, `input_code` will be `0`. - Likewise for `click_events`, `event` has been added and will include the event code for the button clicked. If the event code can be mapped to a x11 button, `button` will still be the x11 button number. Otherwise, `button` will be `0`.
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 98676ce0..9518c62b 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -100,8 +100,8 @@ sway_sources = files(
100 'commands/workspace_layout.c', 100 'commands/workspace_layout.c',
101 'commands/ws_auto_back_and_forth.c', 101 'commands/ws_auto_back_and_forth.c',
102 102
103 'commands/bar/bind.c',
103 'commands/bar/binding_mode_indicator.c', 104 'commands/bar/binding_mode_indicator.c',
104 'commands/bar/bindsym.c',
105 'commands/bar/colors.c', 105 'commands/bar/colors.c',
106 'commands/bar/font.c', 106 'commands/bar/font.c',
107 'commands/bar/gaps.c', 107 'commands/bar/gaps.c',