aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Brian Ashworth <bosrsf04@gmail.com>2019-07-18 01:06:25 -0400
committerLibravatar Simon Ser <contact@emersion.fr>2019-07-23 20:45:46 +0300
commit1a16262903dce09a60f94698afa96c1b2c91c264 (patch)
tree5232ce26dccf8008bcc2cb0cda95dcde382e1c39 /sway/meson.build
parentipc: add an input event (diff)
downloadsway-1a16262903dce09a60f94698afa96c1b2c91c264.tar.gz
sway-1a16262903dce09a60f94698afa96c1b2c91c264.tar.zst
sway-1a16262903dce09a60f94698afa96c1b2c91c264.zip
ipc: add input::libinput_config event
This adds a libinput_config change type to the input event for when the libinput config for a device changes In order for this to be possible to track, the libinput config code had to be refactored. It is now extracted into a separate file to isolate it from the rest of the input management code.
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 934dbe68..157e3996 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -21,6 +21,9 @@ sway_sources = files(
21 'desktop/xdg_shell.c', 21 'desktop/xdg_shell.c',
22 22
23 'input/input-manager.c', 23 'input/input-manager.c',
24 'input/cursor.c',
25 'input/keyboard.c',
26 'input/libinput.c',
24 'input/seat.c', 27 'input/seat.c',
25 'input/seatop_default.c', 28 'input/seatop_default.c',
26 'input/seatop_down.c', 29 'input/seatop_down.c',
@@ -28,8 +31,6 @@ sway_sources = files(
28 'input/seatop_move_tiling.c', 31 'input/seatop_move_tiling.c',
29 'input/seatop_resize_floating.c', 32 'input/seatop_resize_floating.c',
30 'input/seatop_resize_tiling.c', 33 'input/seatop_resize_tiling.c',
31 'input/cursor.c',
32 'input/keyboard.c',
33 'input/switch.c', 34 'input/switch.c',
34 35
35 'config/bar.c', 36 'config/bar.c',