aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Michael Weiser <michael.weiser@gmx.de>2020-03-12 22:10:04 +0100
committerLibravatar Brian Ashworth <bosrsf04@gmail.com>2020-05-13 21:22:16 -0400
commit0f11aa037ad8765abf66e0c90052f9e4c37d56db (patch)
treee78523c566a1a96d53098bfc7c1d1f104043d373 /sway/meson.build
parentImplement pointer simulation if client hasn't bound to touch (diff)
downloadsway-0f11aa037ad8765abf66e0c90052f9e4c37d56db.tar.gz
sway-0f11aa037ad8765abf66e0c90052f9e4c37d56db.tar.zst
sway-0f11aa037ad8765abf66e0c90052f9e4c37d56db.zip
commands: Add per-view shortcuts_inhibitor command
Add a separate per-view shortcuts_inhibitor command that can be used with criteria to override the per-seat defaults. This allows to e.g. disable shortcuts inhibiting globally but enable it for specific, known-good virtualization and remote desktop software or, alternatively, to blacklist that one slightly broken piece of software that just doesn't seem to get it right but insists on trying. Add a flag to sway_view and handling logic in the input manager that respects that flag if configured but falls back to per-seat config otherwise. Add the actual command but with just enable and disable subcommands since there's no value in duplicating the per-seat activate/deactivate/toggle logic here. Split the inhibitor retrieval helper in two so we can use the backend half in the command to retrieve inhibitors for a specific surface and not just the currently focused one. Extend the manual page with documentation of the command and references to its per-seat sibling and usefulness with criteria. Signed-off-by: Michael Weiser <michael.weiser@gmx.de>
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 226e6458..d71846a4 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -99,6 +99,7 @@ sway_sources = files(
99 'commands/seat/xcursor_theme.c', 99 'commands/seat/xcursor_theme.c',
100 'commands/set.c', 100 'commands/set.c',
101 'commands/show_marks.c', 101 'commands/show_marks.c',
102 'commands/shortcuts_inhibitor.c',
102 'commands/smart_borders.c', 103 'commands/smart_borders.c',
103 'commands/smart_gaps.c', 104 'commands/smart_gaps.c',
104 'commands/split.c', 105 'commands/split.c',