aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Brian Ashworth <bosrsf04@gmail.com>2019-01-15 21:25:28 -0500
committerLibravatar emersion <contact@emersion.fr>2019-01-16 11:12:45 +0100
commit02bbefda20b9a4f86e740d33bbaa21c661bb2fac (patch)
tree1b753e414749374be1e144a326a744c4b6812480 /sway/meson.build
parentlayer_shell: do not SIGABRT sway on zero outputs (diff)
downloadsway-02bbefda20b9a4f86e740d33bbaa21c661bb2fac.tar.gz
sway-02bbefda20b9a4f86e740d33bbaa21c661bb2fac.tar.zst
sway-02bbefda20b9a4f86e740d33bbaa21c661bb2fac.zip
bar_cmd_tray_bind: Use mouse button helpers
This modifies `bar_cmd_tray_bindsym` to use `get_mouse_bindsym` for parsing mouse buttons. This also introduces `bar_cmd_tray_bindcode`, which will use `get_mouse_bindcode` for parsing mouse buttons. Like with sway bindings, the two commands are encapsulated in a single file to maximize shared code. This also modifies tray bindings to work off of events codes rather than x11 buttons, which allows for any mouse buttons to be used. For `get_bar_config`, `event_code` has been added to the `tray_bindings` section and will include to event code for the button. If the event code can be mapped to a x11 button, `input_code` will still be the x11 button number. Otherwise, `input_code` will be `0`.
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/sway/meson.build b/sway/meson.build
index c2ed6298..0a08ee74 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -127,7 +127,7 @@ sway_sources = files(
127 'commands/bar/strip_workspace_numbers.c', 127 'commands/bar/strip_workspace_numbers.c',
128 'commands/bar/strip_workspace_name.c', 128 'commands/bar/strip_workspace_name.c',
129 'commands/bar/swaybar_command.c', 129 'commands/bar/swaybar_command.c',
130 'commands/bar/tray_bindsym.c', 130 'commands/bar/tray_bind.c',
131 'commands/bar/tray_output.c', 131 'commands/bar/tray_output.c',
132 'commands/bar/tray_padding.c', 132 'commands/bar/tray_padding.c',
133 'commands/bar/workspace_buttons.c', 133 'commands/bar/workspace_buttons.c',