aboutsummaryrefslogtreecommitdiffstats
path: root/protocols/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar willakat <willakat@users.noreply.github.com>2017-01-07 21:33:02 +0100
committerLibravatar GitHub <noreply@github.com>2017-01-07 21:33:02 +0100
commit653e96f530325f76c2e63befd1f4e916a08c770f (patch)
tree16ae997cc181c0960861e4549b697fa35aed647e /protocols/CMakeLists.txt
parentAdded mouse resize for auto layouts (diff)
parentMIT license (diff)
downloadsway-653e96f530325f76c2e63befd1f4e916a08c770f.tar.gz
sway-653e96f530325f76c2e63befd1f4e916a08c770f.tar.zst
sway-653e96f530325f76c2e63befd1f4e916a08c770f.zip
Merge branch 'master' into master
Diffstat (limited to 'protocols/CMakeLists.txt')
-rw-r--r--protocols/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/protocols/CMakeLists.txt b/protocols/CMakeLists.txt
index ff0a2e4d..a9b459ab 100644
--- a/protocols/CMakeLists.txt
+++ b/protocols/CMakeLists.txt
@@ -22,12 +22,18 @@ WAYLAND_ADD_PROTOCOL_SERVER(proto-server-swaylock
22 swaylock 22 swaylock
23) 23)
24 24
25WAYLAND_ADD_PROTOCOL_SERVER(proto-server-gamma-control
26 gamma-control.xml
27 gamma-control
28)
29
25add_library(sway-protocols STATIC 30add_library(sway-protocols STATIC
26 ${proto-client-xdg-shell} 31 ${proto-client-xdg-shell}
27 ${proto-client-desktop-shell} 32 ${proto-client-desktop-shell}
28 ${proto-server-desktop-shell} 33 ${proto-server-desktop-shell}
29 ${proto-client-swaylock} 34 ${proto-client-swaylock}
30 ${proto-server-swaylock} 35 ${proto-server-swaylock}
36 ${proto-server-gamma-control}
31 ) 37 )
32 38
33set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE) 39set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE)