aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Simon Ser <contact@emersion.fr>2023-12-12 15:25:10 +0100
committerLibravatar Simon Zeni <simon@bl4ckb0ne.ca>2023-12-12 10:04:14 -0500
commitff07eab85b5c6b728ad3cc99d02e9f2ae8b9854f (patch)
treefc4aa760eafe3a14c37fd11d8743c3b54e31de9c /meson.build
parentDrop fglrx detection (diff)
downloadsway-ff07eab85b5c6b728ad3cc99d02e9f2ae8b9854f.tar.gz
sway-ff07eab85b5c6b728ad3cc99d02e9f2ae8b9854f.tar.zst
sway-ff07eab85b5c6b728ad3cc99d02e9f2ae8b9854f.zip
Detect Nvidia proprietary driver via drmGetVersion()
This is less punishing for users with the Nvidia driver loaded but not used by Sway (e.g. for CUDA).
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index adf49c19..e65723b6 100644
--- a/meson.build
+++ b/meson.build
@@ -77,8 +77,7 @@ pixman = dependency('pixman-1')
77libevdev = dependency('libevdev') 77libevdev = dependency('libevdev')
78libinput = wlroots_features['libinput_backend'] ? dependency('libinput', version: '>=1.21.0') : null_dep 78libinput = wlroots_features['libinput_backend'] ? dependency('libinput', version: '>=1.21.0') : null_dep
79xcb = dependency('xcb', required: get_option('xwayland')) 79xcb = dependency('xcb', required: get_option('xwayland'))
80drm_full = dependency('libdrm') # only needed for drm_fourcc.h 80drm = dependency('libdrm')
81drm = drm_full.partial_dependency(compile_args: true, includes: true)
82libudev = wlroots_features['libinput_backend'] ? dependency('libudev') : null_dep 81libudev = wlroots_features['libinput_backend'] ? dependency('libudev') : null_dep
83math = cc.find_library('m') 82math = cc.find_library('m')
84rt = cc.find_library('rt') 83rt = cc.find_library('rt')