aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Simon Ser <contact@emersion.fr>2022-11-26 20:18:43 +0100
committerLibravatar Simon Zeni <simon@bl4ckb0ne.ca>2022-11-28 13:28:15 -0500
commite62299daa45de139b912325eb5800796586e57c7 (patch)
tree5a1972d97bd65000f8e328667f2a772c8622e9e8 /meson.build
parentMake session optional (diff)
downloadsway-e62299daa45de139b912325eb5800796586e57c7.tar.gz
sway-e62299daa45de139b912325eb5800796586e57c7.tar.zst
sway-e62299daa45de139b912325eb5800796586e57c7.zip
Make libinput backend optional
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 5468064f..20ed8424 100644
--- a/meson.build
+++ b/meson.build
@@ -76,11 +76,11 @@ gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: get_option('gdk-pixbuf'))
76pixman = dependency('pixman-1') 76pixman = dependency('pixman-1')
77glesv2 = wlroots_features['gles2_renderer'] ? dependency('glesv2') : null_dep 77glesv2 = wlroots_features['gles2_renderer'] ? dependency('glesv2') : null_dep
78libevdev = dependency('libevdev') 78libevdev = dependency('libevdev')
79libinput = dependency('libinput', version: '>=1.21.0') 79libinput = wlroots_features['libinput_backend'] ? dependency('libinput', version: '>=1.21.0') : null_dep
80xcb = dependency('xcb', required: get_option('xwayland')) 80xcb = dependency('xcb', required: get_option('xwayland'))
81drm_full = dependency('libdrm') # only needed for drm_fourcc.h 81drm_full = dependency('libdrm') # only needed for drm_fourcc.h
82drm = drm_full.partial_dependency(compile_args: true, includes: true) 82drm = drm_full.partial_dependency(compile_args: true, includes: true)
83libudev = dependency('libudev') 83libudev = wlroots_features['libinput_backend'] ? dependency('libudev') : null_dep
84bash_comp = dependency('bash-completion', required: false) 84bash_comp = dependency('bash-completion', required: false)
85fish_comp = dependency('fish', required: false) 85fish_comp = dependency('fish', required: false)
86math = cc.find_library('m') 86math = cc.find_library('m')