aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar emersion <contact@emersion.fr>2018-11-18 00:33:06 +0100
committerLibravatar emersion <contact@emersion.fr>2018-11-18 00:33:06 +0100
commitcad851805bea6b4777685df1c6adf8cb9fa71835 (patch)
tree145fcb048cc3df3d04a8b6afb90de68dd2dd80a9 /meson.build
parentMerge pull request #3142 from RyanDwyer/move-view-properties (diff)
downloadsway-cad851805bea6b4777685df1c6adf8cb9fa71835.tar.gz
sway-cad851805bea6b4777685df1c6adf8cb9fa71835.tar.zst
sway-cad851805bea6b4777685df1c6adf8cb9fa71835.zip
Use #if instead of #ifdef
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 6 insertions, 18 deletions
diff --git a/meson.build b/meson.build
index 8327b763..bb60bc89 100644
--- a/meson.build
+++ b/meson.build
@@ -59,30 +59,18 @@ git = find_program('git', required: false)
59 59
60conf_data = configuration_data() 60conf_data = configuration_data()
61 61
62conf_data.set10('HAVE_XWAYLAND', get_option('enable-xwayland'))
62if get_option('enable-xwayland') 63if get_option('enable-xwayland')
63 conf_data.set('HAVE_XWAYLAND', true)
64 xcb = dependency('xcb') 64 xcb = dependency('xcb')
65else
66 conf_data.set('HAVE_XWAYLAND', false)
67endif
68
69if gdk_pixbuf.found()
70 conf_data.set('HAVE_GDK_PIXBUF', true)
71endif 65endif
72 66
73if systemd.found() 67conf_data.set10('HAVE_GDK_PIXBUF', gdk_pixbuf.found())
74 conf_data.set('SWAY_IDLE_HAS_SYSTEMD', true) 68conf_data.set10('HAVE_SYSTEMD', systemd.found())
75 swayidle_deps += systemd 69conf_data.set10('HAVE_ELOGIND', elogind.found())
76endif
77
78if elogind.found()
79 conf_data.set('SWAY_IDLE_HAS_ELOGIND', true)
80 swayidle_deps += elogind
81endif
82 70
83if not systemd.found() and not elogind.found() 71if not systemd.found() and not elogind.found()
84 warning('The sway binary must be setuid when compiled without (e)logind') 72 warning('The sway binary must be setuid when compiled without (e)logind')
85 warning('You must do this manually post-install: chmod a+s /path/to/sway') 73 warning('You must do this manually post-install: chmod a+s /path/to/sway')
86endif 74endif
87 75
88scdoc = find_program('scdoc', required: false) 76scdoc = find_program('scdoc', required: false)