aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar progandy <code@progandy>2018-11-23 23:14:59 +0100
committerLibravatar progandy <code@progandy>2018-11-23 23:30:46 +0100
commitc4bbd0d3c62e95a2adf7de032db76fa674d95760 (patch)
tree2832a8f4624edda9b547ef64493eb64310865e39 /meson.build
parentMerge pull request #3158 from emersion/get-outputs-focused (diff)
downloadsway-c4bbd0d3c62e95a2adf7de032db76fa674d95760.tar.gz
sway-c4bbd0d3c62e95a2adf7de032db76fa674d95760.tar.zst
sway-c4bbd0d3c62e95a2adf7de032db76fa674d95760.zip
Meson: Fix SYSCONFDIR definition.
SYSCONFDIR was set to the wrong path if prefix is not '/usr' and sysconfdir is an absolute path. Use join_paths() to fix it. Also remove the special case for prefix '/usr'. In that case Meson already sets sysconfdir to the absolute path '/etc', so just using join_paths() will return the correct value. join_paths('/usr/local', 'etc') => '/usr/local/etc' join_paths('/usr/local', '/etc') => '/etc' join_paths('/usr', '/etc') => '/etc'
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 2 insertions, 15 deletions
diff --git a/meson.build b/meson.build
index bb60bc89..810a657e 100644
--- a/meson.build
+++ b/meson.build
@@ -108,13 +108,7 @@ if scdoc.found()
108 endforeach 108 endforeach
109endif 109endif
110 110
111# If prefix is '/usr', sysconfdir will be explicitly set to '/etc' by Meson to 111add_project_arguments('-DSYSCONFDIR="/@0@"'.format(join_paths(prefix, sysconfdir)), language : 'c')
112# enforce FHS compliance, so we should look for configs there as well.
113if prefix == '/usr'
114 add_project_arguments('-DSYSCONFDIR="/@0@"'.format(sysconfdir), language : 'c')
115else
116 add_project_arguments('-DSYSCONFDIR="/@0@/@1@"'.format(prefix, sysconfdir), language : 'c')
117endif
118 112
119version = get_option('sway-version') 113version = get_option('sway-version')
120if version != '' 114if version != ''
@@ -159,14 +153,7 @@ subdir('swaylock')
159config = configuration_data() 153config = configuration_data()
160config.set('datadir', join_paths(prefix, datadir)) 154config.set('datadir', join_paths(prefix, datadir))
161config.set('prefix', prefix) 155config.set('prefix', prefix)
162 156config.set('sysconfdir', join_paths(prefix, sysconfdir))
163# If prefix is '/usr', sysconfdir will be explicitly set to '/etc' by Meson to
164# enforce FHS compliance, so we should look for configs there as well.
165if prefix == '/usr'
166 config.set('sysconfdir', sysconfdir)
167else
168 config.set('sysconfdir', join_paths(prefix, sysconfdir))
169endif
170 157
171configure_file( 158configure_file(
172 configuration: config, 159 configuration: config,