aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Simon Ser <contact@emersion.fr>2023-02-28 16:13:59 +0100
committerLibravatar Simon Ser <contact@emersion.fr>2023-04-14 18:34:54 +0200
commitbd58df61efbb86cd43682acfd7cde8085b503590 (patch)
treee03108b4a06bc940d0a1f03a9b6696b2ca93e420 /meson.build
parentAdd format_str() and vformat_str() (diff)
downloadsway-bd58df61efbb86cd43682acfd7cde8085b503590.tar.gz
sway-bd58df61efbb86cd43682acfd7cde8085b503590.tar.zst
sway-bd58df61efbb86cd43682acfd7cde8085b503590.zip
pango: add printf attribute
This allows the compiler to catch mismatches between the format string and the arguments passed in. Need to add -Wno-format-zero-length because we pass an empty string on purpose in swaybar/render.c.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d1fbfa38..559ee962 100644
--- a/meson.build
+++ b/meson.build
@@ -18,6 +18,7 @@ add_project_arguments(
18 '-Wno-unused-parameter', 18 '-Wno-unused-parameter',
19 '-Wno-unused-result', 19 '-Wno-unused-result',
20 '-Wno-missing-braces', 20 '-Wno-missing-braces',
21 '-Wno-format-zero-length',
21 '-Wundef', 22 '-Wundef',
22 '-Wvla', 23 '-Wvla',
23 ], 24 ],