aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Brian Ashworth <bosrsf04@gmail.com>2018-12-23 10:54:54 -0500
committerLibravatar emersion <contact@emersion.fr>2018-12-25 13:27:08 +0100
commita223030b70c8e360f81b820244705e007e3ac1ec (patch)
tree4e38abb2e27cb567760bab659546ff7176fe49fa /meson.build
parentsway(5): document tiling_drag (diff)
downloadsway-a223030b70c8e360f81b820244705e007e3ac1ec.tar.gz
sway-a223030b70c8e360f81b820244705e007e3ac1ec.tar.zst
sway-a223030b70c8e360f81b820244705e007e3ac1ec.zip
Change mouse buttons to x11 map and libevdev names
This modifies the way mouse bindings are parsed. Instead of adding to BTN_LEFT, which results in button numbers that may not be expected, buttons will be parsed in one of the following ways: 1. `button[1-9]` will now map to their x11 equivalents. This is already the case for bar bindings. This adds support for binding to axis events, which was not possible in the previous approach. 2. Anything that starts with `BTN_` will be parsed as an event code name using `libevdev_event_code_from_name`. This allows for any button to be mapped to instead of limiting usage to the ones near BTN_LEFT. This also adds a dependency on libevdev, but since libevdev is already a dependency of libinput, this should be fine. If needed, this option can have dependency guards added. Binding changes: - button1: BTN_LEFT -> BTN_LEFT - button2: BTN_RIGHT -> BTN_MIDDLE - button3: BTN_MIDDLE -> BTN_RIGHT - button4: BTN_SIDE -> SWAY_SCROLL_UP - button5: BTN_EXTRA -> SWAY_SCROLL_DOWN - button6: BTN_FORWARD -> SWAY_SCROLL_LEFT - button7: BTN_BACK -> SWAY_SCROLL_RIGHT - button8: BTN_TASK -> BTN_SIDE - button9: BTN_JOYSTICK -> BTN_EXTRA Since the axis events need to be mapped to an event code, this uses the following mappings to avoid any conflicts: - SWAY_SCROLL_UP: KEY_MAX + 1 - SWAY_SCROLL_DOWN: KEY_MAX + 2 - SWAY_SCROLL_LEFT: KEY_MAX + 3 - SWAY_SCROLL_RIGHT: KEY_MAX + 4
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6dc5bd8d..e1e0fc2d 100644
--- a/meson.build
+++ b/meson.build
@@ -46,6 +46,7 @@ pango = dependency('pango')
46pangocairo = dependency('pangocairo') 46pangocairo = dependency('pangocairo')
47gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: false) 47gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: false)
48pixman = dependency('pixman-1') 48pixman = dependency('pixman-1')
49libevdev = dependency('libevdev')
49libinput = dependency('libinput', version: '>=1.6.0') 50libinput = dependency('libinput', version: '>=1.6.0')
50libpam = cc.find_library('pam', required: false) 51libpam = cc.find_library('pam', required: false)
51crypt = cc.find_library('crypt', required: false) 52crypt = cc.find_library('crypt', required: false)