aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Alexander Orzechowski <alex@ozal.ski>2023-06-19 13:05:12 -0400
committerLibravatar Simon Ser <contact@emersion.fr>2023-06-19 19:14:28 +0200
commit876687000d4de503cdb01fcd8fa14f1b05dd9a1e (patch)
treeb438f8aa15357a0a4123769f9b8207278636f94b /meson.build
parentinput/libinput: add scroll_button_lock method (diff)
downloadsway-876687000d4de503cdb01fcd8fa14f1b05dd9a1e.tar.gz
sway-876687000d4de503cdb01fcd8fa14f1b05dd9a1e.tar.zst
sway-876687000d4de503cdb01fcd8fa14f1b05dd9a1e.zip
render: Use wlroots scale filter
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 0 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 559ee962..eeee39cd 100644
--- a/meson.build
+++ b/meson.build
@@ -48,7 +48,6 @@ wlroots = dependency('wlroots', version: wlroots_version)
48wlroots_features = { 48wlroots_features = {
49 'xwayland': false, 49 'xwayland': false,
50 'libinput_backend': false, 50 'libinput_backend': false,
51 'gles2_renderer': false,
52 'session': false, 51 'session': false,
53} 52}
54foreach name, _ : wlroots_features 53foreach name, _ : wlroots_features
@@ -75,7 +74,6 @@ pango = dependency('pango')
75pangocairo = dependency('pangocairo') 74pangocairo = dependency('pangocairo')
76gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: get_option('gdk-pixbuf')) 75gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: get_option('gdk-pixbuf'))
77pixman = dependency('pixman-1') 76pixman = dependency('pixman-1')
78glesv2 = wlroots_features['gles2_renderer'] ? dependency('glesv2') : null_dep
79libevdev = dependency('libevdev') 77libevdev = dependency('libevdev')
80libinput = wlroots_features['libinput_backend'] ? dependency('libinput', version: '>=1.21.0') : null_dep 78libinput = wlroots_features['libinput_backend'] ? dependency('libinput', version: '>=1.21.0') : null_dep
81xcb = dependency('xcb', required: get_option('xwayland')) 79xcb = dependency('xcb', required: get_option('xwayland'))